Construction script can't print string

Can you post an image of the Construction graph?

Hi everyone :
I can saw the construction script changed the value of an editable var when I draged around the actor.But the “Print String” node in the construction script doesn’t work.
Any ideas why?

I can’t duplicate the problem, except with a Placed class, which doesn’t show Prints from the Construct.

Print String is a debugging tool, so it is limited to certain uses…

It will work in a Spawned class, though.

(the addition is taking place, though an INC would be more efficient)

I haven’t tried spawn the class in run time.But yes, I directly placed the class in the level and the print didn’t work.
I guess you are right that print string is limited.
By the way ,what is INC ?

Hey Surtur,

This is a known issue: Unreal Engine Issues and Bug Tracker (UE-19924)

Check your output log to see the print string. To access the output log, navigate to Window->DeveloperTools->OutputLog and it will appear for you to view the result of your print string.

Have a great day

INC is short for Increment.

Any time you add exactly one to a variable and save it, you could shorten the process to an Increment.
(and subtracting one to a decrement)

Oh,the ++ operation.
Thank you.

I found the print in the log.
Thank you.

Is this being worked on? I still have this issue.

Aha so this still happens in 4.26.1 (facepalm). Without no reason print string stopped working? EnableAllScreenMessages command doesn’t help anymore? Output Log is full of printed messages?

Solution:
Editor tends to sometimes redirect messages from Viewport1 to Viewport2 from no reason, so just use Viewport2 instead of Viewport1 :wink:

This should be marked as the solution. Thanks!

I thought this was the solution, however, as soon as I Played in Editor, Viewport 2 also stopped working and my construction script messages are only showing on Viewport 3 now. Eventually, I’m gonna run out of viewports. Also started a clean project and it happens again there. The PIE is somehow breaking the ability for Construction Script to print messages to the screen.

I have exactly this issue as well.
I fixed it by enabling “Show Stat” on the viewport options.
Not sure how it got disabled on PIE.