Construct Object from Class (Compiler Error)


I have ran into an issue with this that happens every time I launch Unreal Engine Editor.

The first image shows that I get the ERROR! which ends up being:

Error COMPILER ERROR: failed building connection with "Tech Upgrade Reference is not compatible with Base Tech Reference’. at Construct Object from Class Error ICE: GenericCreateObject error Construct Object from Class

After I have pressed compile it resolves the issue, to me I feel like this has to be a bug if it compiles and runs just fine then it should be all “okay”.

I just have to compile it every time I launch the editor and I think that can get annoying eventually. The goal of this script I am doing is to create a new Tech Upgrade with the Outer being the Tech Upgrade Group itself so I don’t see HOW it won’t work, which it does.

Here is the shot of me compiling it right after I get that error just to show that it DOES compile just I have to do it every time I launch the editor.

I’m sure it is a bug but probably not one that will easily get fixed. I think it just gets corrupted somewhere and causes the issue. I had a similar problem using 4.9.2 and here is what they suggested for me and my eventual thing that fixed it:

Hope this helps!

Hello, yeah I just tried to do something like that and it didn’t work


Have you tried replacing the Construct Tech Upgrade node with a new one, and then reconnecting the pins? It is possible that something with that particular node got corrupted.

Also, have you attempted to reproduce this issue with the same setup in a clean project? If not, go ahead and see if you can recreate that blueprint in a clean project with no additional content and see if you are getting the same error.


I am marking this topic as resolved for tracking purposes, as we have not heard from you in a few days. If this issue persists, feel free to reply to this topic. For any new issues, please create a new Answerhub topic.

Have a great day

I had the same problem. As I understand the problem is in the order of loading and initializing assets during editor startup. I have solved it by adding Construct script into GameInstance child which always loads first. I never execute this code. Example is below on image.

Please I have found new issue connected to this topic with Parent - Child Class.

Construct Object from Class will have the same issue when Parent used in input node class is having any child(s).

You have to castto each child class (which is problem when having multiple child’s).

It will first compile ok in Editor. But after reloading the project to editor - it will be not compiled and you have to compile it each time you launch editor. Also it will crash the packaging of project what makes it really critical.

To reproduce:

  1. Open Editor (any project)
  2. Create a object parent
  3. Create a that object child(s )
  4. Create component or actor
  5. On any event add Construct Object from Class and set this to Parent
  6. Object Class. Compile + save Quit Editor
  7. Open project - in actor Compile error will appear