Constantly crashing when working on material instance window

I have done about as much troubleshooting as an artist can do on this so I would love some expert assistance here!

My bug sounds eerily like something was was supposedly solved awhile back, link here:

My log shows a pattern of a timed out GPU followed by the dreaded XGI_ERROR_DEVICE_REMOVED DXGI_ERROR_DEVICE_HUNG I’ve pasted an example below:

[2017.03.05-04.50.01:475][578]LogD3D11RHI: Timed out while waiting for GPU to catch up. (0.5 s)
[2017.03.05-04.50.01:974][578]LogD3D11RHI: Timed out while waiting for GPU to catch up. (0.5 s)
[2017.03.05-04.50.04:171][578]LogD3D11RHI:Error: Result failed
at D:\Build++UE4+Release-4.14+Compile\Sync\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Query.cpp:134

I have tried upgrading to 4.15 and reverting to older builds but both solutions wouldn’t work with my current project (an indie game). My NVIDIA drivers are up to date as of today 3/4/17.

I thought I found a workaround solution by setting all my Engine Scalability Settings to the lowest possible settings. It helped but not in all cases. By cases I mean I can guarantee a crash if I’m in the Material Instance window plugging in textures to their proper slots, however this is NOT the only case in which I get the engine to crash, sometimes just navigating or placing meshes around will do it but it’s practically guaranteed with material instances.

Aside from me upgrading to a shiny new graphics card if anyone could offer any solutions I would appreciate it as I feel like I’ve hit a wall. Thank you all for your attention on this!

My PC stats are:

Windows 7 Home Premium 64 bit
Intel Core i7-3930k CPU @ 3.20GHz
GeForce GTX 560 Ti

I should also mention that this still happens when using r.gpustatsenabled=0.

Hey Alexander,

We actually have combined all of the various ongoing d3d issues into a collective ticket here: Unreal Engine Issues and Bug Tracker (UE-42280)

You may try the list of workarounds mentioned in the details. I personally have seen the best results from users when they disabled real time thumbnails.

Unfortunately, at this time all we can offer are workarounds to the issue until the investigation is done.