Download

Console Request Form Issue

Hi. I’m developing for switch and having an issue with the console request form. When I fill it in and press submit, the page just goes blank white. It seems like the request doesn’t send. I tried a few different browsers and no luck. What am I missing here? Any help is much appreciated

EDIT: I tried filling the form on mobile and it showed text on the white background saying it sent and they’ll be in touch soon. So it turns out I’ve sent a ton of requests accidentally. I suspect it’s an issue with the DPI settings on my Monitor causing the text to be hidden. Even on mobile the text was partially obscured by the header menu. Oh well it’s sent now so no issue!

Here are a couple of screenshots to illustrate what happened. And why some poor UE employee has about a dozen forms from me in his inbox :sweat_smile:

First pic isn’t zoomed. Second pic is zoomed in the browser and shows the text appearing

I have the same issue. Tried 2 browsers. After pressing “Submit” - white page with the menus.
Tried 5 times.
I think it’s a issue on Epic’s side page. After reading your post I minimize the window until I saw the text.