Console key in Editor with German keyboard layout (non-PIE, non-Packaged)

I only started noticing this after Michael Noland asked me to post a screenshot of an Editor window with certain stats enabled using the console…but it seems that both 4.7.6 and 4.8p1 have issues with a german keyboard layout.

Using Project Settings > Engine > Input > Console keys, I got the following keys assigned:

42341-editor-input.png

IMO “Zirkumflex” and “^” are the same, just a different binding. All of them work in a packaged build and in PIE, except for the grave accent “`” - but none of them work in a plain Editor session thats just sitting there, or a BP/Tileset/Material editor for example.
At first I thought this is related to those keys being dead keys on the german keyboard, but even keys like F12 or ö (which certainly isn’t a dead key!) do not work as expected within the Editor.

Switching to a different keyboard layout in Windows (such as “English (USA)” or “Japanese (Japan)” with IME) don’t seem to make a difference to the running Editor.

What works is going to Window > Developer Tools > Session Frontend and typing the console command into that window. However, that only works for the main Editor window; not for other Editors such as BP/Tileset/Material.

OS: Windows 7 SP1 x64 German
Keyboard Layout: QWERTZ “Deutsch (Deutschland)” (aka. “German (Germany)”…even tho I’m from Austria)

Tested on:
4.7.6 Launcher Version (4.7.6-2513093+++depot+UE4-Releases+4.7)
4.8 Preview 1 Launcher Version (4.8.0-2536902+++depot+UE4-Releases+4.8)

Hi BhaaL,

I was able to reproduce this and have entered a bug report, UE-15466 to be assessed by the development staff.

I have the same problem in v4.15.1.
What works though is setting the “^” key in Editor Preferences > Keyboard Shortcuts