Consistent issues opening CineCameraComponent.generated.h

Hi all, I’m attempting to create a reference to a UCineCameraComponent* in a SceneComponent I’m creating, but I’m getting a consistent error when attempting to do the following:

#include "Runtime/CinematicCamera/Public/CineCameraComponent.h"

and create any form of reference to a UCineCameraComponent.

The error comes out as:

After trying to regenerating my solution (as past forums suggested for similar errors) multiple times and multiple ways to no avail, I tried to make a new UE4 project on another machine. I simply created the Blank Project, added a new scene component, and wrote the aforementioned include statement at the top of its cpp… and the same error occurred when I tried to compile.

I’ve also tried to include and reference other types of components to see if I’d get a similar error, but all of the other components I’ve tried totally cooperate. What I did notice, however, is that all other classes in “Runtime/CinematicCamera/Public/” have trouble being referenced as well, with the exception of “CinematicCameraModule.h” – each give the same “Cannot open include file: name.generated.h” error when trying to compile/

Everything I’ve seen and tried points me towards the idea that the Runtime/CinematicCamera/Public folder has problems, and if that’s the case, I really have no clue what to do. I hope the problem is on my end thought because that would be much easier to fix.

Any and all help is greatly appreciated, and let me know if any further information is needed!

Solved! Added “CinematicCamera” in the list of dependencies in the .uproject file, then refreshed the Visual Studio Solution from the editor!


You hero - thank you!


Thank you :slight_smile: