Download

Confusion (maybe bug) with animation length and keyframes

In my usual workflow a looped animation has the first and last frame the same. Let’s say I have an animation in 3dsmax that runs from frame 0 to 8 (same pose in 0 and 8).
After importing it into UE, the animation runs from frame 0 to 9, so at least visually (anim preview gui) it looks lake the animation plays for 9 frames, but the length in ue is correctly reported to be 0.2666…

It’s even obvious that the “poses” in different frames in UE don’t match those in 3dsmax. It looks like animation time length is ok, and only visually it’s scaled to “number of frames in animation +1”. For example, frame 4 pose in 3dsmax is actually frame 4,5 in UE. Just to be sure how this is handled in other engines, I tried to import the animation into Unity and there it seems to be exactly as in 3dsmax (ending with frame 8).

Is this a bug or there is some intention/logic behind this?

Hey there,

this is odd. When I import my animations from Blender to UE4 it displays correctly the amount of key frames. In the import settings I used ‘Exported Time’.

Could it be that you are not animating in 30 fps and when importing, UE4 scales your animation somehow?

Hi, I’m sure I’m working with 30fps in 3dsmax. Here are screenshots of the same animation, timeline in max and UE:

&stc=1

As I said, time wise, they have the same length. Even key count reported by UE is correct (frame 0 is frame too). Only problem is that the same stuff is visually stretched to the 9th frame (which would be 10th keyframe if we count frame 0).

Have you tried checking “Use Default Sample Rate” on import?

Yeah, tried that and no difference.