Concave UCX_ collision mesh not working (Blender)


I’m testing how to set up a custom concave mesh in UE4 and not having a lot of luck.

For my game, I need to have a different visual mesh to my collision mesh, and the collision mesh needs to be concave.

To test this, I have a placeholder visual mesh (in this case a bowling pin) and a collision mesh. The visual mesh is called ‘Pin’ and the collision is called ‘UCX_Pin’. You can see the set up in Blender below:

The UCX_Pin file is one whole shell with no unwelded verts or other gaps.

When I import this into UE4, the concavity of the UCX_Pin file is ignored:

If I use ‘complex as simple’ then I get all the faces from the visual mesh, not the custom UCX_Pin mesh.

I’m probably missing something really obvious here. Any suggestions would be much appreciated!

when you import the mesh try setting auto generate collision to false and set one convex hull per ucx to true. hopefully those options are still the same in 4.19 (the screenshot below is from 4.17)

Hi! Thanks for answering.

I’ve used those exact settings but no luck - the same collision is generated. (I copied the LOD group setting from your image too, setting it to ‘none’ where previously I had used ‘large prop’ but that hasn’t made any difference.)

Do you have any other ideas please?

… Just updated the level to 4.19 (I didn’t realise I was running it in 4.18) and the import options are different - there is no mention of UCX concave settings - but the same thing still happens, so the latest engine is still doing this.

The Importer work correct…you Need two UCX for your Scene! See the Picture

You can select the faces in the edit mode and then press P to make it seperate…rename it like in my picture. it work

you shouldnt need to do that. ive made what the person is describing before and imported with 4.17.

Okay, it’s a good news - bad news situation.

The good news is that breaking the mesh apart worked… On the second attempt!

Bad news:

The naming convention appears to need to be (in my example)



Doing this works! Hurrah!

Except, when you split something in Blender it is automatically renamed:




So, everything will need to be renamed by hand to change Pin.001 to Pin_001. This isn’t such a problem with this test, when it can be split easily into two pieces, but if I do a long curving wall, then every few paces will need a new UCX_ mesh, and every piece will need to be renamed by hand. The renaming-by-hand bit is time-consuming and annoying… But if that’s what needs to be done then that’s life, it just seems like this must be such a common thing that it doesn’t feel right!
Is this a bug for 4.18 and 4.19? Surely a long concave curve on a corridor wall or on a race track doesn’t need to be made with a new collision UCX_ piece every few meters?

I want to also say ‘thanks’ for the replies so far! We’ve got to the point where I have a functional fix, it just seems like the engine might have a deeper problem here - especially if, as @ThompsonN13 says, a solid with a concave part could have been imported correctly in version 4.17 (although I’ve had a quick try in 4.17 and I can’t get it working).

So… Is there a bug here, or is Unreal really this bad at dealing with concave UCX_ meshes?