Components stuck in absolute transform

Hello, after upgrading to 4.12, all my splines components have been set to absolute.

Here you can see where the Pivot is for one spline, along with the spline component itself (and all the others).
They are all in 0,0,0 world position, and moving the pivot no longer moves their component.

I’ve tried things like this in the constructor, beginplay, etc.

Spline->AttachToComponent(RootComponent, FAttachmentTransformRules::KeepRelativeTransform);
Spline->SetRelativeLocation(FVector(30, 0, -100));
Spline->SetAbsolute(false, false, false);

But no matter what I do, they’re 100% absolute. That code even moves them to 30,0,-100 world position.

Any ideas how to fix this?

Fixed, for anyone else with a similar problem:


This was set elsewhere in the code, with all the splinemesh components attaching to the spline component.
It worked finr in 4.11, but in 4.12 unreal no longer likes spline being static, and everything breaks.

Solution was to attach the static splinemeshes elsewhere and to leave spline as movable.