Download

Components gone in blueprint?

Somehow I can’t find my Components in the Viewport anymore? as far as I can see everything is still working as expected?

I’am using 4.7 Preview 8 so probably it will be some problem there…

It is only that one ‘PlayTable’ blueprint that is missing everything in the viewport. Anyway to ‘debug’ this problem? because now I can’t make any changes anymore to the blueprint component layout

Anybody else had this kind of problems? Am I missing something? (a setting or anything like that)

Thanks in advance for helping me out!

Btw I already tried resetting window layouts / reset camera and the meshes simple aren’t there. (Construction script and Event graph are alright)

Have you tried selecting a component from components tab and then hitting F to focus?

Hi Mate

Near “Perspective” to the left is a little drop down arrow.

Choose - reset camera with a component selected.

Narg

Thanks for the sugestions but I can’t get them back… I also checked the ‘meshes’ i’m using and they all looks fine. Also adding new objects isn’t working they just will not become visible. (I see them in my map1 / game view though)

So it seems only the ‘blueprint viewport’ is not working.

Is this happening only in that blueprint or do you have the same issue if you create a new BP? If it persists in every BP could you please report this in AnswerHub?

Probably i’am mis understanding something but I found out what is causing my problem.

See screenshot:

I’am the eventgraph of the blueprint which is giving me this ‘problem’ (maybe not even a problem if I mis understand how ‘destroy’ actor works)

I added the ‘Destroy Actor’ in the understanding that would ‘destroy’ the object and count a point for the right player. So the game can continue by spawning another one. As soon as I add it and go to Viewport everything will be removed from the view. (probably destroyed) :slight_smile:

Anybody know what I don’t understand here?

Thank you. This got my components back in the viewport.

Same problem, destroy actor.

Ty.

Im also having this issue in 4.12 this is a bizarre issue since the blueprint isnt simulating or in play mode. So for me to fix it. I got rid of my player reference and went back to cast to third person character and this fixed the issue.