"Component Replicates" no longer displayed in Editor

After one of the recent updates, the whole section of “Component Replication” properties, along with “Component Replicates” flag, disappeared from blueprint components extending ActorComponent. The flag still appears on SceneComponent’s descendants.

Apart from disabling the ability to make newly created components replicate, it also hid the property on already existing components. As a result, Blueprint Diff on a component, which I haven’t made any manual changes to, looks like this:

Browsing ActorComponent’s header, I found out that UCLASS indeed has a param “hideCategories=(ComponentReplication)”, but what baffles me is that, according to git blame on this file, the line hasn’t been changed since April 2015. Also, I don’t see an apparent reason for hiding this functionality from users.

This looks like a very serious bug, especially since it has a potential to corrupt the behaviour of old blueprints in a way that’s extremely hard to spot.

Hey Czyzk,

In which version of the engine was this option available for you?



I’m sure it was available in 4.11. As for which exact edition of 4.12 made it disappear, I unfortunately don’t know.

i’ve noticed this as well, i’ve resorted to enabling it in blueprint in constructors

Well, that works, but has 2 downsides. Obviously there is the amount of work required to find every place where it’s necessary to add it. Most importantly though, it makes the component no longer a Plug&Play blackbox for designers.

indeed, i hope we get this feature back soon

Hey Czyzyk and BPANDREW,

I have put in a feature request to make Component Replicates exposed in ActorComponent Blueprints again. You can track the status of it here: https://issues.unrealengine.com/issue/UE-34433

Until then, if you have the source code, you are able to fix this before he development team decides to work on it. If you don’t already know how to get the source code, you can find out more information here: [][2]


Hey all. This bug has been tormenting me for days, causing me to believe that replication for ActorComponents was broken. After reading this thread, I’m glad to see it’s a simple issue and there is some visibility on it.

Have you been able to get the source code workaround to work? I’ve removed the hideCategories=(ComponentReplication) from the class definition of ActorComponent, but it doesn’t bring the “Component Replicates” back to the Class Defaults panel of my ActorComponent subclasses. Is there another source code workaround for this? I understand the constructor workaround (which is my current approach) but I would really like to expose the checkbox again, if possible. Thanks!


removing the aforementioned code fixed the problem for me. As far as I remember, after removing it and building the engine, I was surprised to find out that the checkbox is still missing, but recompiling component’s blueprint brought it back.

This does not work for me. I have recompiled and run the editor with the code fixes, removed the Intermediate/ and Binaries/ directories, and modified and then recompiled the blueprint for my ActorComponent subclass. Still no checkbox. :frowning:

The page at UE-34433 marks the bug as “Fixed” as of Oct 6 (in 4.14.0), but I still do not see the “Component Replicates” option in Class Defaults for ActorComponents after upgrading to 4.14.0. Should I be looking somewhere else?

If you upgraded your project, the option may not be available. Try a clean 4.14.0 project and see if you are able to see the Component Replicates option in that.

Great, but I would like this feature in my current project. Is there any way to enable this feature in my upgraded project?

It’s possible that assets created using the previous version that was experiencing this issue are not being properly updated to add the option to blueprints. Could you do me a favor and confirm this by creating a new actor in your project and seeing if newly-added components contain the Component Replicates option?

This functionality appears to be working again in my project (recently updated to 4.14.1). Thanks for the fix!