Complex Collision for Overlap on Static Meshes


I am having some difficulty getting overlap effects to work properly on one of my blueprinted static meshes. It’s just some water that uses begin/end overlap events to cause water effects [floating, wetness, etc] but it’s in a semi-sphere shape, and requires accurate collision/overlap boundaries in order to function properly.

The model is very large in the world, so using the generated collision [even on highest settings] causes the overlap effects to occur very inaccurately. Complex collision as simple obviously gives accurate collision bounds, but seems to generate the overlaps as if the model is hollow, calling begin overlap and then end overlap shortly after, even while I am still in the mesh. It seems to be treating only the surface of the mesh as the “volume” so once my character collision ducks under the water, it ends the overlap and treats it like it’s outside the water volume.

After a bit of research, it seems that using complex collision as simple on static meshes is a bit wonky when getting overlap events, so is there any other way I can achieve this?

Edit: It appears that the only way to achieve per poly collision is through “complex collision as simple”. Unfortunately, it seems to treat my mesh as hollow whenever I try to get an overlap event with this setting. I have tried it on many different meshes, and it seems that unreal just doesn’t like to give proper overlaps with this setup. It gives me the begin overlap correctly, but once a character/object fully enters the shape, and stops touching the walls of it, it ends the overlap, even though the object is still inside the shape. I’m stumped.

creating a custom collision mesh would be a better idea and then import it to ue4 created from a modelling tool.

and a water tutorial won’t be a bad idea to use if U wanna see

The custom collision seems to be the way to go. However, I seem to be having an issue with it. I’ve exported the UCX properly [with the right naming conventions] and have custom collision imported. However, it seems to be importing a very low detail version of the mesh for some reason:

As you can see, it imports the UCX collision no problem, but it seems to keep it very low detail. Here’s what it looks like before being imported:

Any ideas? [I placed the collision mesh above the model so it’s easier to see, don’t worry, it’s not meant to go there.]

well have u tried importing it as different objects rather than together

please have a look at how the person does this…

or U can try this out

His tutorial does the same thing that I have done. My issue is that the collision mesh I export is much higher poly than the one unreal is importing/generating, and I need it to be a per-poly collision. But as stated in the original question, simply setting the collision to “use complex as simple” causes massive overlap issues [likely a bug]. Since I need it to be per poly, as my collision model is, using the collision generation won’t work, as it doesn’t match my shape exactly.