Download

Compiling within editor complains about changes to generated files

I’ve posted this question in the AnswerHub, but I was wondering if anyone here had seen this issue.

I’ve been working on the project for a week, and added classes, everything was working fine. Whenever I added a UPROPERTY or UFUNCTION, I had a “Changes to generated code are not allowed” errors, and I would close the Editor, and rebuild the solution in VS 2013, reopen the Editor, and Compile. It would work fine.

Today however, that error just won’t go away. Whenever I compile in the Editor, I get the error, even though in VS everything compiles fine. I’ve tried cleaning, deleting the Intermediate directory, nothing seems to work.

If I create a new project and add a class, it works fine. Obviously something in my configuration for that project is broken. Any ideas?

Solved it, finally. I right-clicked the .uproject file in my project folder, and selected “Generate Visual Studio Files”. I then opened the project, changed the configuration to Development/x64, and it no longer complained about the generated file.