Download

Compiling windows project on OSX - "The following modules are missing or built with a different ..."

Hi all,

I’ve a project which compiles fine on Windows, but when I try to open the .uproject file on my mac I initially get a popup with the following:

Missing XXXX Modules
The following modules are missing or built with a different engine version:
UE4Editor-XXXX.dylib
Would you like to rebuild them now?
If I chose No, the UE4Editor just closes.

If I chose ‘yes’, then the build window appears. If I chose ‘show log’ I see some warning about precompiled headers, but the window vanishes too quickly to see details.

I then get another pop up:

Error
XXXX could not be compiled. Try rebuilding from source manually.

Help? I can imagine that I should delete some files so they get recreated by the build system … but I’m not sure what. I also can’t seem to find the logfile, unfortunately.

I’m a bit lost.

Cheers,

Ed

So, there are some small differences between the compiler and the standard libraries in the Mac and Windows build environments for UE4.

On your Mac, find your .uproject file and right-click on it. In the Contextual Menu, find “Services” and select “Generate Xcode Project”.

A terminal window will pop open. A few seconds later, it will say that it’s done, and you can open the brand spanking new .xcodeproj file in Xcode. Make sure you select “[ProjectName]Editor - Mac” as your build target and “My Mac” as the device. IIRC, it doesn’t always default to these.

Now, ⌘B to build the project. You’ll likely get an error when it builds. There’s a small chance it’ll build fine - I have seen times when something odd happens and I can compile fine from Xcode, but launching the project and letting it compile fails. More likely, though, you’ve got something in your project that doesn’t work on the Mac. You might’ve called a Windows-specific function that doesn’t exist or you might have used a Windows-specific constant or #pragma that LLVM doesn’t recognize.

After it fails, look at the build log. You should get an error in there that gives you some clue as to where the problem is. If you don’t understand how to fix it, post it here and I’m sure we can get you compiling.

Thank you very much! That got me further, but now I’m running into the following… I have some code which has:

Probably unsurprisingly I get the following:

I’ve been trawling through the documentation, but I can’t see :
a) what the AllowWindowsPlatformTypes and HideWindowsPlatformTypes are supposed to do
b) what you should do under OSX

I’ll try making some simple dummy projects to see what code they generate, but if anyone has any pointers to useful documentation that would be superb!

Thanks again!

I’m having similar build problems trying to build Rama’s Victory Blueprint Library plugin. The error code my Xcode gives me is



ExternalBuildToolExecution UE4Editor\ -\ Mac
    cd /Users/Shared/UnrealEngine/4.9
    export ACTION=
    /Users/Shared/UnrealEngine/4.9/Engine/Build/BatchFiles/Mac/RocketBuild.sh UE4Editor macosx DebugGame

Setting up Mono
Building UE4Editor...
Creating makefile for UE4Editor (no existing makefile)
Performing full C++ include scan (no include cache file)
Compiling with MacOSX SDK 10.10
ERROR: Rocket: No modules found to build?
Command /Users/Shared/UnrealEngine/4.9/Engine/Build/BatchFiles/Mac/RocketBuild.sh failed with exit code 5


It gives me this error regardless of whether or not Rama’s VBL plugin is present in the project directory. However, with the plugin installed in the Plugins folder in my project directory, launching the Editor gives me an error as described in the OP.

Build target and destination:
cc6c9b781510832f613a664a3ba992124ef7548e.png
ccd1c6044e3761b2bbb56b8a298f3dddc32531f9.png

PS
I run Mac OSX 10.9.5. The base SDK says it’s for OSX 10.10. I’ve tried switching it to 10.9, but it has exactly the same result.

So here’s the problem I’m getting. Any suggestions? Also, I couldn’t find where to change build target and device, which may well be one of the problems.
370d2661556965e20bddb34fb5b265aba10bba2d.png

I keep getting the same too.
But when i compile and run within the editor, it works fine.
Does anyone know how to solve this issue on RocketBuild.