Download

Compiling shaders stuck in 4.26

Hi all,
I have a problem with the new version of Unreal 4.26. After creating a new project and add new level shaders start compiling but stuck. I tried all the “workaround” that I found on the internet. Nothing helps me. But in version 4.25 everything working well, could you help me, someone, to fix it?
Thanks a lot

I solved my problem. I had to reinstall my computer, clean install windows, it was the last thing on my list. Now everything working well.

Jesus Christ

Hi community!
I have the same problem with my newly installed Unreal Engine 4.26.1. In 4.25 everything worked fine. In 4.26.1 the Shader compiler starts but does not compile anything! Anyone have any ideas how I can fix the error?

Thanks.

Hi, yes I had the same problem. Nothing helped, again nothing! I had to reinstall the whole system (format system disk) then after clean install 4.26.1 working well. And trust me, I tried everything that I find on the internet. What I mean:

  1. update - ShaderCompiler.cpp
  2. update - r.XGEShaderCompile = 0 (ConsoleVariables.ini)
  3. Uninstall EpicLauncher and again install - delete all data
  4. Update EpicLauncher, Windows, graphic drivers

Bumping for having the same issue. shader compilation stucks at some point. each shader-compile-worker is using cpu and up to 2 gig of ram each but no progress at all.

Dear Epic Games, I have the same issue. Everything compiles perfectly on version 4.25, but even if I try to use simple meshes and materials imported with DataSmith my shader compilation won’t move on version 4.26. I tried to uncomment the line in .ini file and change the process priority, it just shows that the process is using my graphic card but the process won’t move. It looks more like UE4 is trying to raise some Bitcoins with my hardware rather than to compile shaders. If anyone fixed this problem, please, write the solution in this thread. Thank you.