Compiling Blueprint remove setu for UStaticMeshComponent

This is my Actor class:
#pragma once

#include "GameFramework/Actor.h"
#include "Voxel.generated.h"

class VOXELSPROJECT_API AVoxel : public AActor

	// Constructor
	AVoxel(const FObjectInitializer& ObjectInitializer);
	// Voxel mesh
	UPROPERTY(EditAnywhere, BlueprintReadWrite, Category = Voxel)
	UStaticMeshComponent* VoxelMesh;

	UPROPERTY(EditAnywhere, BlueprintReadWrite, Category = Voxel)
	USceneComponent* SceneComponent;

	UPROPERTY(EditAnywhere, BlueprintReadWrite, Category = Voxel)
	UStaticMesh* StaticMesh;

	void Tick(float DeltaSeconds);

Based on this class I create BP in editor. When I setup UStaticMeshComponent in blueprint editor and compile it, editor remove whole setting for UStaticMeshComponent.

Hi Xender,

I am very sorry for not responding to your post sooner. I tried to recreate this issue in a simple project, but I was unable to do so. Would you be able to provide some additional information about this issue?

  • What version of the Engine are you using?
  • Are you using the binary version installed by the Launcher, or did you build the Engine from source code?
  • Could you please provide the code in the constructor for your class?

It was enginer downloaded by launcher, 4.6.
I remove thats old code and replace it with new, so I dont remember how to reproduce problem, sorry.

Hi Xender,

I just tried to reproduce this issue again using the binary version 4.6.1 installed by the Launcher. I was still unable to recreate the results that you described. I will mark this issue as resolved for now, but if you run into this again, please let us know and we can dig into it again.