Compile failed - Unable to load module 'ScriptGeneratorPlugin' - 0 instances of that module name found

ue4 asks me 2 recompile the module b4 my char class will appear in the content browser howevr it fails evrytime I’m trying 2 compile it
I got w7 and vs2017 with c++ and ue4 components
I used this tutorial 2 setup vs 4 ue4
some1 knows what’s going on here?

just tried that and it failed :<

Hi @j3lly_m3lly , have you tried closing the editor and building from Visual Studio?

Typically you will see this message when you are including a plugin or module that doesn’t exist or is misspelled in your build files. I’m not in front of the codebase right now but my inclination is that the script generator plugin has been removed or refactored. Look at your project’s .uproject file, and your game target.cs files to find any reference of this module. If you find it, just remove that from the list of included modules/plugins

Let me know what you find.

After looking more at this… ScriptGeneratorPlugin is definitely still in the codebase. If you still need help, you gotta show us the .uproject and build/target.cs files you are using


I made my repo and uploaded those files here:
GitHub - j3lly-m3lly/ue4c-

btw is it possible that it may b caused by some ue4 plugins that r incompatible 2gether 4 example?

I added some of them when I made this project

mayb my vs needs c# components?
I thought only c++ will b needed so it doesn’t have c# components

ehh so it looks like I’m totally screwed at this point(…) :confused:

only thing left is 2 remove plugins and if it doesn’t work, I will have 2 reinstall whole ue4 and see if that works by any chance >,o