Compile Error Xcode Mac Os x

Hi, I bought Unreal Engine 4… Clone the source files from github to my pc… download the 2 requires zip, create the project but then when i run the compilation on Xcode it tell me a Shell script error “wchar.h - file not found” How i can resolve that!!

Thank you

Could you please attach full output from Xcode. Also, what Xcode and Mac OS X version do you use?

Hi tried with two Mac : iMac with Osx Yosemite and Xcode 6, and with a macbook pro with Osx Lion and Xcode 4. no one work. What did you mean with full output?

Lion and Xcode 4 are too old, you need Mavericks SDK to compile the engine. As for Yosemite, I haven’t tried compiling the engine on it yet. I’ll give it a try later today and get back to you. I didn’t have any problem building with Xcode 6 on Mavericks, though.

By full output I meant full build log from Xcode, not only the error text.

Put the log in a compressed zip or rar file, and attach the file here.

Thank you very much.

I can’t post all the log… it’s too long…

link text

OK, thanks, now I know what’s wrong. UnrealBuildTool assumes Xcode is installed in /Applications and the app name is If you have only Xcode6 beta installed, it cannot find the SDK. You can either rename your Xcode6 app to Xcode, or edit Engine/Source/Programs/UnrealBuildTool/Mac/MacToolChain.cs and change DeveloperDir path (line 35). That should fix the problem.

Please note that so far we only tested UE on Yosemite very briefly and we can’t guarantee you won’t run into any other issues. We will start full testing soon and will have full support by the time Yosemite is released, but for now we have no idea how well it works.

That said, if you do have further problems on Yosemite, let us know, we’ll do our best to help.

Thank you very much! It Work! but theres another problem :\

I chose the FPS Project but it tell me “failed to generate project files for ( directory)”

Please go to ~/Library/Logs/Unreal Engine and find a log file editor created. Maybe it’ll tell us more. Thanks.

Looks like your Mac has GeForce 9400, which is below UE4 system requirements :frowning: We added partial support for OpenGL 3.3 cards (not all of them, though) in UE 4.2, but we never tested that on Yosemite and at this moment I can’t think of anything else I could suggest. To be honest, even if you’d install Mavericks and it’d render correctly, it’d be very, very slow.

Now, when i start UE4Editor all app is Grey…link text

Ok, well i’ll try with another PC, Thank You very mach for all :slight_smile: