Compile crash after running project

I’ve been having a problem where the editor crashes every time i attempt to build blueprints, any time after I run it. Similar crashes have been happening since Unreal Engine 4.11, but not with such pinpoint consistency. If it doesn’t crash, the editor will just hang indefinitely instead.

I’m currently running Mac OS X 10.11.4



StaticDuplicateObject(UObject const*, UObject*, FName, EObjectFlags, UClass*, EDuplicateForPie, EInternalObjectFlags) Address = 0x110104300 (filename not found) [in UE4Editor-CoreUObject.dylib]
UWidgetBlueprintGeneratedClass::InitializeWidgetStatic(UUserWidget*, UClass const*, bool, bool, UWidgetTree*, TArray<UWidgetAnimation*, FDefaultAllocator> const&, TArray<FDelegateRuntimeBinding, FDefaultAllocator> const&, UWidgetTree*) Address = 0x11b55565c (filename not found) [in UE4Editor-UMG.dylib]
UUserWidget::Initialize() Address = 0x11b549168 (filename not found) [in UE4Editor-UMG.dylib]
StaticDuplicateObjectEx(FObjectDuplicationParameters&) Address = 0x1101059c1 (filename not found) [in UE4Editor-CoreUObject.dylib]
StaticDuplicateObject(UObject const*, UObject*, FName, EObjectFlags, UClass*, EDuplicateForPie, EInternalObjectFlags) Address = 0x110104458 (filename not found) [in UE4Editor-CoreUObject.dylib]
FBlueprintCompileReinstancer::FBlueprintCompileReinstancer(UClass*, bool, bool, bool) Address = 0x117e34b8b (filename not found) [in UE4Editor-UnrealEd.dylib]
FBlueprintCompileReinstancer::Create(UClass*, bool, bool, bool) Address = 0x117e77b33 (filename not found) [in UE4Editor-UnrealEd.dylib]
FKismetEditorUtilities::RecompileBlueprintBytecode(UBlueprint*, TArray<UObject*, FDefaultAllocator>*, bool) Address = 0x117e1f58d (filename not found) [in UE4Editor-UnrealEd.dylib]
FBlueprintCompileReinstancer::ReinstanceObjects(bool) Address = 0x117e1c779 (filename not found) [in UE4Editor-UnrealEd.dylib]
FKismetEditorUtilities::CompileBlueprint(UBlueprint*, bool, bool, bool, FCompilerResultsLog*, bool, bool) Address = 0x117e18064 (filename not found) [in UE4Editor-UnrealEd.dylib]
FBlueprintEditor::Compile() Address = 0x11ccd2a7f (filename not found) [in UE4Editor-Kismet.dylib]
TBaseSPMethodDelegateInstance<false, FBlueprintEditor, (ESPMode)0, TTypeWrapper<void> ()>::Execute() const Address = 0x11cdee91b (filename not found) [in UE4Editor-Kismet.dylib]
TBaseSPMethodDelegateInstance<false, FBlueprintEditor, (ESPMode)0, void ()>::ExecuteIfSafe() const Address = 0x11cdee9bb (filename not found) [in UE4Editor-Kismet.dylib]
FUICommandList::ExecuteAction(TSharedRef<FUICommandInfo const, (ESPMode)0>) const Address = 0x1161e9a4d (filename not found) [in UE4Editor-Slate.dylib]
SToolBarButtonBlock::OnClicked() Address = 0x1163411de (filename not found) [in UE4Editor-Slate.dylib]
TBaseSPMethodDelegateInstance<false, SToolBarButtonBlock, (ESPMode)0, FReply ()>::Execute() const Address = 0x1163f46a1 (filename not found) [in UE4Editor-Slate.dylib]
SButton::OnMouseButtonUp(FGeometry const&, FPointerEvent const&) Address = 0x116439045 (filename not found) [in UE4Editor-Slate.dylib]
FSlateApplication::RoutePointerUpEvent(FWidgetPath&, FPointerEvent&) Address = 0x1161bad9f (filename not found) [in UE4Editor-Slate.dylib]
FSlateApplication::ProcessMouseButtonUpEvent(FPointerEvent&) Address = 0x11616a9e4 (filename not found) [in UE4Editor-Slate.dylib]
FSlateApplication::OnMouseUp(EMouseButtons::Type, FVector2D) Address = 0x1161c3cbe (filename not found) [in UE4Editor-Slate.dylib]
FMacApplication::ProcessEvent(FDeferredMacEvent const&) Address = 0x10f44aada (filename not found) [in UE4Editor-Core.dylib]
FMacApplication::ProcessDeferredEvents(float) Address = 0x10f44a72f (filename not found) [in UE4Editor-Core.dylib]
FSlateApplication::TickPlatform(float) Address = 0x11618c595 (filename not found) [in UE4Editor-Slate.dylib]
FSlateApplication::Tick() Address = 0x11618bb68 (filename not found) [in UE4Editor-Slate.dylib]
FEngineLoop::Tick() Address = 0x10f207475 (filename not found) [in UE4Editor]
GuardedMain(wchar_t const*) Address = 0x10f20e5cf (filename not found) [in UE4Editor]
-[UE4AppDelegate runGameThread:] Address = 0x10f21ef2c (filename not found) [in UE4Editor]
-[FCocoaGameThread main] Address = 0x10f443776 (filename not found) [in UE4Editor-Core.dylib]
Unknown() Address = 0x7fff9bda8d64 (filename not found) [in Foundation]
_pthread_body Address = 0x7fff92ffa99d (filename not found) [in libsystem_pthread.dylib]
_pthread_body Address = 0x7fff92ffa91a (filename not found) [in libsystem_pthread.dylib]
thread_start Address = 0x7fff92ff8351 (filename not found) [in libsystem_pthread.dylib]

Hi Takanu,

It looks like your recent crashes are referencing a “StaticDuplicateObject()” and are related to UMG in your Widget Blueprint. For troubleshooting purposes, I suggest:

  • Running Build>Map Check
  • Building Widget Blueprint to check for errors
  • Package your game to desktop and check log for errors.

Try these and post your results.



Hey, thanks a lot for the assistance. It seems like i’ve narrowed down the crash to two particular UMG elements that utilised Event Dispatchers, and some issues with the Content Browser not showing, deleting or saving properly certain assets.

I cleared the Asset Registry Cache and checked that old files weren’t hanging around in content folders still in the Finder, and that fixed it.

Hi Takanu,

I’m glad to hear you found a work around and thanks for submitting your crash reports when they occurred. This has aided in helping us to pinpoint the cause of the crash previously reported as UE-31570 which has recently been reported fixed for a future release of the engine.