Compile Code Menu Missing

For some reason, my compile code button in the editor has gone missing. I have VS2013 professional installed, and UE4 can find it as the Open Visual Studio and Add Code To Project menu items work correctly. It used to work for this project, but, stopped today for some unknown reason.

I’ve seen a few other posts on here about this. I have verified by my environment variables for visual studio are correct.

How do I get the in editor code compilation back again?

If I create a new project, the compile code button exists in the editor again. So this is somehow related to some change in my actual game project.

Hey, ThomasPittman.

This thread: [Question] Where did my compile button go? - Pipeline & Plugins - Epic Developer Community Forums
Says that if VisualStudio doesn’t have the right solution loaded, then it won’t display the compile button. It really shouldn’t be possible for this to happen if you have VisualStudio set up perfectly.

So, let’s try some stuff. Have you tried making a duplicate of your project and loading that one up? Maybe loading up an older version? How complex is your project? Copying the whole dang thing into a new project (with a working Compile button) is a nuclear option that should work if you have to.

Let me know if any of that works,

Jonathan

Hi Thomas,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.