Download

Compilation problem

I started getting compilation errors and I am not sure what is causing them. The error messages don’t give me much info and I don’t know even where to start trouble shooting. I did change if I accidentally change the engine code and I didn’t.

Here are the first few lines of error messages in the hope that someone will recognize the problem:



...
19>  PCH.UTG.UTG.h.cpp
19>d:\dev\projects\ue4\engine\source\runtime\coreuobject\public\uobject\UObjectHash.h(52): error C2440: 'default argument' : cannot convert from 'EName' to 'FName'
19>          Source or target has incomplete type
19>d:\dev\projects\ue4\engine\source\runtime\coreuobject\public\uobject\UObjectGlobals.h(10): error C2504: 'FLogCategory' : base class undefined
19>d:\dev\projects\ue4\engine\source\runtime\coreuobject\public\uobject\UObjectGlobals.h(10): error C2143: syntax error : missing ',' before '<'
19>d:\dev\projects\ue4\engine\source\runtime\coreuobject\public\uobject\UObjectGlobals.h(10): error C2039: 'Log' : is not a member of 'ELogVerbosity'
19>d:\dev\projects\ue4\engine\source\runtime\coreuobject\public\uobject\UObjectGlobals.h(10): error C2039: 'All' : is not a member of 'ELogVerbosity'
19>d:\dev\projects\ue4\engine\source\runtime\coreuobject\public\uobject\UObjectGlobals.h(10): error C2614: 'FLogCategoryLogUObjectGlobals' : illegal member initialization: 'FLogCategory' is not a base or member


The problem is fixed, by I’d still like to know why it happened.

I deleted Intermediate/Build, removed all code except the precompiled header, it’s cpp and game mode class and build the project - it build correctly. Then I brought everything back and there where no compilation errors. At least I think that’s all have done.

It happened again. Project just started showing those same compilation errors. Add again, the solution was the same.

The error appeared after I modified the precompiled header to include <vector> in it. First time it happened it was also around the time I modified precompiled header to include <memory>. So now I am wondering if the problem has something to do with editing the precompiled header.

Thought I did modify it once to add <cassert> and didn’t get there errors.

Still happening in 4.2

Well i’m no getting that error and guess nobody else too, how do you grab the UE4 code?

Based on the messages, check your UE_LOG messages and see if something is wrong.

If you can’t find anything, post the contents of the Output window when you get this error. There should be more detail including the original line causing this error. MS C++ isn’t very good about their error reports in the Error List and leave a lot of info out.