Compilation issue: no changes after compilation

Hello everyone! I’m using UE4.27 and Rider for UE 2021.2.1 for C++ project.
It looks like the same version of the project is running, regardless of the changes made. Compilation completes without any errors/problems but changes in code have no effect. I reverted to a very old commit, but the results are still the same. Also I’m tried to rebuild current project (in Advanced Build Actions) and do some obvious thing with restarting UE4/Rider, etc.
Removing all files from the list in .gitignore helps, but temporarily - the second and subsequent compilations do not work correctly, so you have to repeat this removal every time. What can I do with this?

Found a solution: when compiling, you need to check if DevelopmentEditor Win64 is selected (for some reason, it sometimes changed on its own).

Yup, found this to be the same. Also deleting Intermediate and Binaries can help when changes don’t appear in BP after C++ changes. Then do Clean > Rebuild.