Compaile Failed (C++ only)

Hello.My name is Igor. I’m not so smart and poorly versed in programming, so please, if anything, try to explain to me in a simpler language. I downloaded Unreal Engine a couple of hours ago in order to try myself in the role of a game creator, preliminarily watched a couple of lessons on Unreal Engine, including installation. When I started the installation myself, I ran into a number of problems. At first I looked at the games that were made using “blueprints” and I did it, but still it was more interesting to write code using C ++ and when I decided to look at a couple of ready-made projects, I ran into a problem, I got an error "Compile Failed "and I saw just what I am turning to you now : The project could not be compiled. Would you like to open it in Visual Studio?

Running E:/Games/Epic Games/UE_4.22/Engine/Binaries/DotNET/UnrealBuildTool.exe Development Win64 -Project="C:/Users/bvaco/OneDrive/Documents/Unreal Projects/MyProject3/MyProject3.uproject" -TargetType=Editor -Progress -NoHotReloadFromIDE

Creating makefile for MyProject3Editor (no existing makefile)

@progress push 5%

Parsing headers for MyProject3Editor

Running UnrealHeaderTool "C:\Users\bvaco\OneDrive\???㬥???\Unreal Projects\MyProject3\MyProject3.uproject" "C:\Users\bvaco\OneDrive\???㬥???\Unreal Projects\MyProject3\Intermediate\Build\Win64\MyProject3Editor\Development\MyProject3Editor.uhtmanifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -Unattended -WarningsAsErrors -installed
Reflection code generated for MyProject3Editor in 6,5742596 seconds

@progress pop

Using Visual Studio 2017 14.16.27023 toolchain (C:\Program Files (x86)\Microsoft Visual Studio\2017\VC\Tools\MSVC\14.16.27023) and Windows 10.0.17763.0 SDK (C:\Program Files (x86)\Windows Kits\10).

Building 11 actions with 12 processes...

@progress 'Compiling C++ source code...' 0%

@progress 'Compiling C++ source code...' 9%
  [1/11] Default.rc2

@progress 'Compiling C++ source code...' 18%
  [2/11] SharedPCH.Engine.cpp

c1xx: fatal error C1083: ?? 㤠???? ??????? 䠩? ?஬????????? ??? ???????????: C:\Users\bvaco\OneDrive\?"?????????????'?<\Unreal Projects\MyProject3\Intermediate\Build\Win64\MyProject3Editor\Development\Engine\SharedPCH.Engine.h.pch: No such file or directory,

The solution to this problem, I am sure, lies on the surface, but due to my poor knowledge of English and knowledge of computer programs, I could not solve it myself. I tried to search for information on Google, but, as you can see, I didn’t succeed, although I was still able to solve a couple of problems myself.

I would be happy to read every answer on this issue. I believe that you will help me.

(and of course, if you have good advice on UE, I will be glad :D)

try to remove Russian symbols in your path