Comment Color Box Forces Restart

4.12.2 I was changing comments colors and then closed the dialog box, working in a widget BP event graph. When I tried to PIE I got the error in the picture.

No comment dialog color selectino box was open and I even went through all comments created in that session and opened and closed/set their colors to no avail.

Hello Nsomnia,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any settings/ other blueprints that may be involved?

Yeah I know the process and it seems quite random but I will try in the enxt day or so.

It seems to be on a fresh blueprint with mulitple blueprints open, make a comment in all (say 3) event graphs on nodes and then color htem one at a time. Compile them and save them. Then comment color them all and on the last one try to PIE.

Reproduction on clena project.

Create an actor class BP called BP_ActorBP
Create a game instance inherited class called called GI_GameInstanceBP
In BP_ActorBP actor bp create an event begin play and connect it to a print string node compile and save
In GI_GameInstanceBP gameinstance bp do the same but before saving select the grey “Comment” comment and then use the color box and USE THE COLOR PICKER and select the dark red color from the event beginplay node. Ok that color
Select the color again and choose a custom opacity I used 0.5 and copy the color code.
Compiel and save GI_GameinstanceBP
Paste the color code into the BP_ActorBP grey comment box color picker and hit ok then compile and save
Go back to GI_GameInstanceBP and try to PIE. You get the error.

Everytime for me.

Seems to be selecting with the color picker causes that error forcing a restart. As if the color picker box isnt removed from the top of heap/active window && just hidden or something.

I have run through the steps provided several times and I was unable to reproduce this issue on our end. Would it be possible for you to provide a sample project that produces this error?

Will do asap with a video. Very annoying when commenting on team projects but maybe I’m the only one. Tried verifying engkne files twice.

Hello Nsomnia,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.