Collisions are not ignored when root motion is applied


I have a problem with animations that have root motion enabled and I hit a dead end so I’m now here hoping you’ll be able to help me. :smiley:
I’m using an animation with root motion enabled so that the character can climb a ledge and I’m disabling his collisions so that the capsule can go through the mesh. The problem is that the capsule fails to go through the ledge mesh (even though collisions are disabled and I’m sure of it because after playing the animation the character falls through the floor). I am also setting movement mode to flying but this doesn’t seem to help either. Also, an odd thing is that when I remove the ledge actor from the world when the character is playing root motion he starts to fall (even though the capsule was never touching this mesh).

So, any ideas? :slight_smile:

I have fixed the issue. Some other code was changing the movement mode of the character while playing the animation.