Collision (Scene Depth) not working on a GPU particle

Hey guys!

I am following the tutorial for particles from the official YouTube channel. I’ve gotten to the GPU sprite part, and I have problem with the collision. It doesn’t collide with my meshes or brushes (I converted the brush, I thought that might have been a problem.)

Here is a screenshot.

I am using version 4.3

So, what did I do wrong here?


Hi Motanum -

What is your response set to, Stop, Bounce or Kill? Also when you converted your brush did you check to make sure the generated mesh has collision. If not add a Box-Simplified Collision and test again.

Thank You

Eric Ketchum

Thanks for the answer! I changed back to a brush, even added a chair for testing.

The response is set to bounce. You can see the particles just going through.

Now the collision for GPU particles work on Scene Depth so if you camera is not rendering the floor than no collision will occur. For instance:

Your newest image seems to have this problem whereas your old image seems to just be the lack of a collision object. Try to look at your particles from a downward angle and see if they do not bounce. Also try increasing the Const Acceleration I am using something around -750 on Z. Just trying to pull those particles downward to make sure that they are still alive to produce that bounce.

Let me know -

Eric Ketchum

Thanks for the quick responses, but still no luck.

the original acceleration was -980 on the Z.

Tried to take the picture from the top down, and added an extra brush to the scene. the chair aint colliding either.

Hi Motanum -

Can you upload your particle system’s *.uasset file for us to test or if you can give me a screenshot of your various modules’ detail panels so I can make sure I reproduce your exact particle system?

Thank You

Eric Ketchum

Sure thing! Here you have, the particle system and the material it uses.

Thanks man! That worked!

Hey Motanum -

Uncheck “Use Local Space” in the Required Module and collision will work fine. This is because the Collision on GPU particles calls from Scene Depth and cannot function in local space.

Thank You

Eric Ketchum

I have the same issue but I have unchecked “Use Local Space” and get the same problem

same here - did you find a fix?

Nope no fix yet