Collision problems

So I recently got hired as a contractor (Level Designer) on this project and one of my tasks is to import all current assets into UE4. The prototype level was done for the most part in UDK, however all rooms were already modeled in another 3ds/Maya (IE there is no modular construction in the prototype.). The rooms are all square shaped and the collision worked fine inside the UDK from what I saw, I was able to run around the 3 rooms and what not.

HOWEVER, once I imported the exported assets into UE4 I could not walk around the rooms anymore. I would try play from here and just get sent to some empty part of the level. I tried putting a player start within one of the rooms and I get a bad size error, and the same thing happens as before. I tried importing the original assets since I figured maybe it was just the export/import that screwed the collision and still I get the same error. I have also tried adding collision to the mesh itself BUT when I do that it treats it as a box and it gets me nowhere.

My question is am I missing something in the import process or is there some issue with rooms being already boxed out and built? Am I being a total newb? I know the engine is new but I cant be this dense as to not be able to figure this out. Help!

Hi ,

Where are you importing your assets? Does the issue occur if you import them into, say for example a Starter Project such as Third Person Blueprint which has a character that has all the components for movement assigned?


First thing I’d check is scale. By default, one Unreal Unit is one centimeter. This means the old-style scaling typically used in UDK (which I think worked out to something like 16 units per foot) will be problematic. Try scaling your content up by the appropriate ratio, given that each unit is a centimeter.

Don’t recalculate normals and binormals.Check if you FBX is updated and point the mesh normals to look inside ( if i understand you’re using a box as a room).

This is what ive tried so far.

I have tried importing the FBX into the 3rd person blueprint starter. Still the same problem.

I have tried just a blank map with nothing, still the same problem.

Initially I thought that it was possibly the fact that I imported a bunch of rooms with preset collision, but it will only use the first rooms collision. I read this on the documentation page for importing FBX’s. However, this also is not the case as I just got home and imported a singular room and still have the same problem.

I think you may be onto something Zak. I will link this thread on our Basecamp and perhaps our modeler can make some sense of this.

Everything is right on the modelers end with with the custom collision. So it may be a scaling issue, any other thoughts?

If you can, just arbitrarily scale the room up and try putting a PlayerStart back in it. It’s sounding more and more like your level is just too small.

Thanks Zak, ill give that a whirl, if anything ive already rebuilt it with BSP! Though it took forever!