Collision problem when a mesh wakes up


I noticed a problem when I wake up a static mesh. For a short time after setting “Set simulating physics TRUE”, the mesh can penetrate any other mesh but if I wait a little then collisions are working normally.

Here is what I do :

  • Put a mesh inside a open container and deactivating its physics simulation
  • Grab the mesh with a physics handle and reactivating its physics
  • If I don’t move the mesh during a short time then it collides normally with the container
  • But if I move it right after grabbing it, it will go through the container

I tried many things like CCD and substepping but nothing seems to affect this behavior. It’s like there is a short period after a wake up when collisions are ignored.

Is it a bug or can I do something to prevent this?


  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • Does this occur with all physics objects, or is it limited to a particular asset (for instance, a skeletal mesh vs. a static mesh, etc.)?
  • What collision settings do you have on your physics object?


We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.