Download

Collision Problem - Projectile colliding with character capsule

How do I make a projectile not collide with the owner? At certain angles my projectile explodes instantly, I think I have narrowed it down to my character capsule. If I make it smaller, it doesn’t collide but my characters collision is WAY too small. Extending the spawn point causes my projectiles to fire through the terrain when looking down

https://www.youtube.com/watch?v=EErnOv-VPqw

Hello,
On your event hit / overlap : “other actor” output not = ( “get player character” / “cast to” your character.) branch : true : do your event. Then character will be ignored.

Hi Fen, this half works. My projectile is no longer exploding but now when it collides with the capsule it just stops in mid air haha. Step in the right direction.

Would this be solved if I had a full character mesh and used that for projectile collision and turn On Ignore Projectile on the Capsule?

I found this solution while looking up a C++ function

“How to prevent a projectile being blocked by the instigator”
https://answers.unrealengine.com/questions/42020/how-to-prevent-a-projectile-being-blocked-by-the-i.html

"I used the function MoveIgnoreActors() defined in UPrimitiveComponent. In the PostInitializeComponents() function, I simply added the Instigator to the list of IgnoreActors using this function. I also did the reverse on the Instigator itself (ie added the spawned projectile into the list of IgnoreActors for the Character).

**In Blueprints, this can be achieved by using the function ‘Ignore Actor’ called from the Actors’s collsioncomponent **or the mesh itself (if there are no separate collisioncomponent defined)."

So, Event Begin Play, pull out your collision component for the projectile. From that pull a ignore actor and set your character index or instigator as the target

Cool to know that, thanks, i’ll try to remember it ^^