Collision Problem on Vehicle Model-Skeleton Importing From Maya

Hello People,

We have been suffering from a problem that happened in Vehicle system in Unreal Engine. Approximately more than a month ago I posted a question to answerhub. The link is:

https://answers.unrealengine.com/questions/104207/vehicle-wheel-collision-problem.html

Thanks to Jacky, he tried to help us, he solved the issue and posted working vehicle system in asset files to hub. But still we cannot make our own models work in Unreal. As I understand, he is well experienced in 3ds max but not in maya. Unfortunately our designers work in Maya and we couldn’t solve the problem.

I’m gonna paste the text from answerhub directly to above.

Here is a video about the issue:
http://www.youtube.com/watch?v=8eShfghfwjY

You can find the screenshots in answerhub
https://answers.unrealengine.com/questions/104207/vehicle-wheel-collision-problem.html

We tried every possibility in export options in Maya and import options in Unreal. Nothing has changed. I know most of the people are using Maya just like us, I think this problem could not be related to Maya-Unreal incompatibility, both of the softwares are well-known and widely used by community.

Weird thing is that, when we get some working model from somewhere, import it to Maya and re-export it to Unreal without changes, still could not get a proper working vehicle.

My question is for Maya users, did you experience such problems? Also any comment, any idea would be precious as like diamond for us, we stucked and cannot go further.

Thank you in advance.

how have you set up the wheel blueprints?

I used same blueprint, vehicle blueprint, game mode etc. with Jacky’s posted one, I’m quite sure the problem is not caused due to wheel blueprints. Just like I said in my previous post, we get a working vehicle fbx model from internet, after importing it to Unreal, it works as expected. But if we put it to maya, without any changes export-import to Unreal again, -without any changes-, result become as in the video.

Looking at this image in your video, the Box collision on the root bone (body) is extending down too far, you don’t want the box to be any lower than the underside of the car. Try adjusting it and see if it helps. :slight_smile:

Thank you for your answer, but we have already tried to get root collision to be realistic like, down-z position starts from car’s body, neither zero position nor wheel positions. I’m afraid its not the solution. The weird thing is that, Unreal only detects body(root) collision which means that box you mentioned. It does not recognize wheel collision “if we link wheels to the anim blueprint system”, otherwise collisions works perfectly, but as you can guess, vehicle does not move.

Also there is a thread that our designer posted on Autodesk’s forums about this issue:
http://forums.autodesk.com/t5/maya-general/vehicle-wheel-collision-problem/m-p/5348425#M21011

Yes that is normal, the wheel collision is not used, but you can’t have the main body box collision down that far, it just won’t work. What’s happening when you can’t move the vehicle is the body’s box collision is hitting the ground before the wheels do, not allowing the wheels to move. Here is my working vehicle setup (image 1), if I try and make the box come down to the ground like in the image above, the vehicle won’t move either.

Also in your video when you have a wheel collision cylinder selected, and the Z-axis is pointing in the direction that the Y-axis should be, with the Y-axis pointing downwards. Can you check the rotation of the wheel bones in maya (if you are using bones)? It looks like they are rotated by 90 degrees, try selecting a bone and switch over to rotation mode and check the values to ensure they are all 0.0,0.0,0.0 as this has caused problems for others in the past. You can see the difference in the 2 images below, looking at the XYZ axis gizmo, it is pointing in the wrong direction. This could also be caused by exporting an FBX with the “Y-Axis Up”, check in the fbx export options when you export from maya and ensure you have it set to “Z-Axis Up”.

Hope that helps :slight_smile:

EDIT: I am also a 3dsMax user, don’t really know much when it comes to maya unfortunately so there could be something I am missing, but looking over what Jacky had said on Answerhub there must be something going on with X-Form as mentioned, either rotations are off or X_form transformations are causing an issue, sorry I am not sure how this can be fixed in maya, hopefully a maya expert will be able to help here as well.

I just has similar issues over the weekend (I use Cinema 4D), I had to keep changing orientation of my joints until the ended up being imported the right way into UE.

To start with I had to model and rig along the ‘right’ axis instead of forward and have my Z pointing down on the joints etc.

Basic mesh/car but it looks like this, the key being that then when imported all the axis’ of all the joints match UE world axis’

Maya will be 90˚ out even when in Z-Up mode too, trial and error should get you there.

That should not be the problem, by the way I forgot to mentioned, we applied reset transform to the model after Jacky’s suggestion. And currently skeleton of the model seems like:

And problem still goes on, DotCam.

Btw, just ignore the space in wheels :stuck_out_tongue:

Hey man, if you send me a PM with a link to the fbx I can have a look at it in maya & 3ds (and UE4) to see what the issue is and compare the 2. I’m not great with maya but I might be able to help find out what’s going on here. :slight_smile:

Of course, here is the fbx file :slight_smile:

http://burakertugrul.com/files/ProblematicCar.fbx

Hey Burak,

I still dont have a solution to this problem unfortunately. But i watched your video and checked the new FBX myself(i had to pass the file through Max first, delete the bones, reset xform, merge chais meshes and then link wheels to the chasis), and things go nuts the moment i plug the animation BP to the vehicle BP. There was another user(3ds Max this time) having this sort of issue last week and it was caused by crazy transforms. Your vehicle should work but i dont know why bones are acting weird with anim BP. Hope DotCam can see what we are missing.

Good luck!

It looks like all of the bones are rotated 90 degrees on the X axis (in 3dsmax), in maya it shows 0,0,0 but the co-ordinates are different. In the image below I have only the root bone selected, but the other 4 wheel bones are also rotated the same way.

Try rotating only the bones -90 degrees on the X axis (for each), you might need to remove the skinning first, and this will require the car to be re-skinned afterwards as well unfortunately, but it is the only issue I can see between the 2 programs. I am no good at maya, otherwise I would try it out myself, but would most likely just make things worse. :smiley:

The car mesh is not one solid object, but I don’t think that is an issue here as the skinning should take care of that, I’ll keep looking to see if I can come up with anything else for you. :slight_smile:

Dotcam, Jacky, Anadin, Smokey13 thank you very very much for your helps. We finally got rid of that problem.

Anadin has sent a fbx file that shows the correct way to rotate root bone. We have applied same solution to our model from scratch and it worked. Before exporting the model to Unreal, we gotta rotate root bone in x axis -90 degree. But wheel bones should be the same value with world’s coordinate’s axis values.

But I must say that it’s really really weird issue and newbies like us cannot handle with that easily. We have tried every other possibilities by rotating wheels or rotating car completely. I couldn’t understand why root bone should have a different axis setup than world’s axis.

My final worlds, I’m deeply appreciated for your helps. Thank you :slight_smile:

No problem! Great to hear you finally got it working! :slight_smile:

I will add this info on Maya, as well as other troubleshooting tips for vehicles to a wiki tutorial article in the coming days as there have been a few small issues that have come up recently. As you mention there needs to be a bit more info documented for new users, each program seems to have a slightly different setup procedure. Thank you for letting us know you got it working!

That would be absolutely great for new Unreal users :slight_smile:

Yeah I am hoping the new transform modifier the importer has in 4.6 will work down the whole heirarchy. That way we can model in our chose DCC ‘Up’, ‘Forward’ and ‘Right’ and fix it to match UE’s when importing.

its a lot of trial and error to get thing right.

Hey, thanks guys, I had this same issue, took me 2 days to find this thread and fix the problem… Like Burak says, it’s a really weird issue :open_mouth: Anyway, thanks to all of you :wink:

ez way fix maya, 100%
:stuck_out_tongue:
http://prntscr.com/erenu7

Still doesn’t work for me.

Hey guys. I’ve rotated my wheel bones -90, but the problem still happens. Its starting to stress me out and I’ve got all the correct stuff ( Working physics actor, wheel BP’s, Etc) As I’ve worked on my project for a year, it would be a large let down to have to remove one of the biggest aspects in my game. If anybody can help me, it would be deeply appreciated. I’m using Ue4.14.