Download

Collision Presets -- Not doing anything?

Trying to take an in-game item and make it have no collision with pawn mesh so players can walk through the item like a water pipe or electrical cable.

I have tried changing all the presets, even gone as far as coping over all the inheriting classes and re-linking them on my own and changing all the collision presets there, no dice.

Is there something I am missing here?

Also, it seems to be that there is ultimately a parent class that you cannot even see the settings on, such as ‘Primal Structure Water Pipe’. Is this something else I am missing here?

Bump. Would really like some insight on this, even if you don’t have a solution but maybe an idea of where to dig.

There is a check box in the blueprint
Ignore Pawns
Might be what you’re looking for.

Red: Try that first, if you haven’t already. You’ll need to change the preset to custom to enable changes.

Purple: Last resort, disable collision completely.

-WM

yup done all of that, even set everything to ignore all expecting it to fall through the world. Still no change.

These are with elevator track bases btw. even had a buddy test under his ADK and got the same result.

Even with collision disabled completely, i still can interact, place and run into it just as if there was no change.

The ONLY way I have been able to walk through the elevator track, is to delete the collision box on the static mesh and make my own mesh file and link to that.

But then, the player can no longer interact with the object at all, as to be expected with no collision box.

Oh yeah, didn’t think to check the static mesh.

Try this - probably plug it into Event Begin Play (with a delay, 0.1 is plenty); “Get My Static Mesh”

-WM

delay to what? You cannot link a completed delay to a component such as My Static Mesh unless this is something else I am not doing right. But from everything I can see, it wont link.

http://puu.sh/loImU/0935381f66.jpg

HOT ****!

Thanks!!

Just so people know, it is a hair janky due to the delay (0.1 was the lowest I could go without it breaking), but I have yet to find any other way around this.

Event Begin Play is glitchy, and eight times out of ten will need a delay of at least 0.1 to fire correctly.

Safe can always be played by creating the node and leaving it at default, there’s a reason it defaults to 0.2.

And that was what I meant, by using the delay (“with a delay”).

-WM

well, it was kinda glitchy when i left it at 0.2 but when I changed it to 0.1, all the lag in getting through the item went away, even server side. So id say it works pretty well.

Thanks mate!

http://puu.sh/lpv5C/8c26d734ef.jpg

Redid it a bit to clean it up/remove uneeded things. Also added in protection to keep the server from crashing if it is at a low FPS.