Collision only been detected on first few bones of skeletal mesh


Hello all, quite new to unreal so any help would be appreciated, i have imported a chain i rigged in 3ds max as a skeletal mesh and added the physics asset, the chain had 10 bones rigged to it but when i place it in the level it seems only the first top 3 bones are respondeing to collision, i did scale the bones in the phat tool becasue of unstability so not sure if that had anything to do with it? it still a bit unstable but settles after a second, i have collision enabled and physics enabled as physics actors but only the top 3 bones are detecting it?, any help please?.

Think it may of been down to the size of the mesh it was a 10 metres big fat chain i reduced it’s scale and took out a few bones and seems to be working ok.