Download

Collision on imported PolyPlane not working!

Hey there! I have tried all kinds of methods, collision through the Mesh Editor, importing a UBX, everything. But I cannot seem to get collision working on this polyplane. Anyone know what the problem may be?
4bcf6636246bcee09904efc0dacd8cbed6b3ba8b.jpeg

When you used UBX, you made sure it matched with the actual mesh name upon export? For example UBX_Energy for the collision, and Energy for the name of the actual mesh?

Yeah I did exactly that and it just didn’t work :confused:

I can’t really make out too many details with the screenshot you provided, but is there an actual collision shown in the mesh editor, but it isn’t working? Or is there none at all shown in the mesh editor? I can’t really remember off the top of my head, but there may be a checkbox you have to tick when importing the fbx. Did you check that as well?

Well the editor shows no collision at all, as for when importing, which checkbox is it? 'cause I didn’t see anything about collision when importing other than UCX, and I was using UBX.

I don’t remember if there was one or not, my editor is updating so I can’t look atm. If the editor isn’t showing collision at all then all I can think of is its an issue with the mesh naming. What modeling package are you using, and can you show how you set your model up before export?

I’ll load it up and take some screenshots, I’m using Maya 2014. (the fact that Maya’s FBX is 7.4 and UE4’s is 7.3 wouldn’t have anything to do with it would it? all the other models had collision)

I actually don’t know, that could be a possibility. In maya you should have UBX_Energy as the name in the transform and mesh input area for the collision, and Energy for those inputs of the actual model. Do you have a lower version of maya you could try to test compatibility with if that’s the issue? Or is it possible to download FBX 7.3?

Well here’s the screenshot:
a5742c1b875fdc83e9d42023e403bbd797ef1550.jpeg
I suppose I could load up Maya 2012 on my laptop and try it that way if that’s the case.

You have shape after UBX_Energy in the mesh input. Write it exactly how it is shown in the transform input (UBX_Energy rather than UBX_Energyshape). Do the same for your actual mesh, make sure it doesn’t have shape written in it, and try again.

I’ll give it a go! :slight_smile:

Let me know if that works for you, I think it should fix your problem. =)

Haha yeah it worked. You were right…I’ve been working all day on this I guess that’s a sign I should go to sleep! Thank you VERY much for your help! :slight_smile:

Happy to help! Good luck, and get some rest! =)

Try using UCX as the pre-fix for the collision. Also make sure that your collision has the exact same name as your mesh. For example if you mesh is called Box then your collision mesh should be called UCX_Box.