Download

Collision on for specific materials or faces of a mesh.

I made a tree in blender and imported to unreal. I generated collision but found out that not only the trunk, but the leaves were blocking me. Is there a way to disable collision for materials or generate it for the trunk only? Otherwise I’ll have to create a separate mesh for the leaves just so I can pass through them.

You would need to create the collision in the 3d program as you should probably have done in the first place.

You can always also edit and remove bits/parts of the collision by deleting the generated primitives directly from the editor.

You will have several “primitives” listed inside the Collision section.
Worse comes to worse you can try to delete them.
First enable Simple Collision in the Collision drop down. this will display the collision meshes.
Then you can literally select and delete visually.

Hope that helps.

Inside the mesh’s asset window there should also be a window panel “convex decomposition” (if not then in the asset window go to Window>assetDecomposition) which you can use to auto generate colliders. This should help you to get an appropriate shape for the trunk and, as MostHost said, you can delete the colliders on the leaves\canopy.

–When I say “asset window” I mean the window that pops up when you double click on the trees static mesh in the content browser

For very large trees, simple collision will look bad, especially if the trees have large roots. You can use “Use complex collision as simple” in the collision details, then in LOD0, in the material slot for the leaves, turn off “Enable collision” for this material. Complex is more expensive but obviously more precise.