Collision not working

Hey, I’m a beginner at UE4 and the collision is not working for any kind of mesh. I tried selecting BlockAll, BlockAllDynamic, and other options and even tried custom collision but of no use. It wasn’t working on UE 4.19 and isn’t working on UE 4.20. I tried this in many different projects but again, of no use. It is also not working in static mesh’s properties and in sphere in the blueprint. Can anyone please help me with this one?
Thanks in advance!

It is also not working in static
mesh’s properties and in sphere in the

So if you create a new template project and put a cube in the level, the collision is not working?

Image from Gyazo

I’m going to gloss over the fact that I’m also colliding with the floor here…

You’ll need to be more specific, saying that nothing is working is not helpful. Could you demonstrate an example; as seen above?

Actually, I was adding a proper answer and the gif got commented by an accident :smiley:

So, I am trying to make an archery game but whenever I fire an arrow it goes through the ground. I set the value in collision section of sphere collision in the blueprint as block all as BlockAll as the tutor in the tutorial did but his arrow was blocked by the ground and mine was not as below.

And in another project, the firstPersonCharacter wasn’t colliding with the rock provided in Starter Content. Even though I changed the collision settings to BlockAll and I checked the Simulate Physics box but still no collision.

Open the static mesh by double clicking on it - add simple collision:


Do you have any at all?

I was editing my answer when you deleted your thing ;p

Check if your mesh has collision:

Plus every time I add simple and complex collision as you stated, every time I open that menu again it’s gone and I have to add those collisions again even though if I save

So if you add collision, save, close, and reopen, it’s gone?

Strange things happen when you have 2 instances of the same project opened at the same time. Make sure you haven’t accidentally opened the editor twice. Strange as it seems, it does happen (to me).

Yeah, it is gone and no, my editor isn’t opened twice. I searched everywhere for this but could find the solution nowhere. Is it possible that I might have downloaded the beta version of UE 4.20.2? BTW many thanks for all your help :slight_smile:

Can you post a screen shot of your collision properties for the mesh and player character? Make sure “enable overlap events” is ticked as well. Also check the hierarchy of your mesh, does the collision sphere inherit from something higher up that isn’t set to collide properly? These are all common problems I would look into.

These are my collision properties and I checked everything you said and everything is in the right order as you told.

What does the hierarchy of the arrow actor look like?

When you say you added collision, did you just click the Simple Collision checkbox and the Complex Collision checkbox for the collision previews? And when you did,did you see any wireframe shapes appear on your staticmesh asset preview?

Yes, I did check them and when I closed the editor and opened it again those checkboxes were unchecked again even though I saved it.

Sorry, I’m a newbie. I didn’t get what actor? Are you talking about the arrow or the sphere? and what hierarchy?

Show collision is just for showing, you can’t save it. Did you actually add collision. Do you see the green boundary?

Have a look at the last image I posted, the one with wavy arrow. The green spherical boundary shows the simplified collision. You can also see it as the primitive where the arrow points.

Exactly. Those checkboxes only show what collision you have added, they don’t actually put collision stuff on your mesh.