Download

Collision Mesh

Hello

I have an asteroid with tunnels in it I have a collision mesh setup with UCX_Asteroid but upon importing in engine I see an auto generated collision, preventing from entering the tunnels.

http://8pic.ir/images/wahvu3b9pt3d3shrestj.jpg

http://8pic.ir/images/zpht59w8wcfb5z5kd48e.jpg

Help is urgently needed. :slight_smile:

Disable “One convex hull per…” in the import settings :slight_smile:

Not quite like it :frowning:

http://8pic.ir/images/9c6nxhqbiryhqqeoxvud.jpg

This mostly happens when there are some vertices not connected with the mesh/the mesh is not “closed” like a convex hull :slight_smile: -> so check your collision mesh again

It’s all ok, just confused why it’s not working.
PMing you the model, I’d appreciate it if you take a look to see if it works on your end.

Ok, will check it :slight_smile:

Vertices that seem close enough can cause exploded out points like that but you can weld them together in the vertex menu. You can run through your mesh and just make sure all points are welded as they should be. Also check the area of “influence” of each vertex to see if they are majorly overlapping anywhere which can cause that infinite exploding. You can do this in the vertex menu.

Edit: I should read better! I didn’t see you sent it in PM. I’m sorry. Good luck!

Ok, it’s fixed now, but I’m not sure how exactly I fixed it :stuck_out_tongue:

  1. I imported the mesh into blender
  2. scaled it up + exported it
  3. imported it into the ue4 - in the settings I disabled “auto generate collision” + “one convex hull per…”
  4. it works

But mostly those problems are caused by the upper mentioned reasons :slight_smile:

Hmmmm… No overlapping, open edges or anything. So I have to PM you the next models again if this happened since your hand does magic.
Thank you for the help. (I might as well stay awake for a full 24 hours cycle to see when you got o sleep) :wink:

@Lindsay Aries, Thank you too, for the reply. :slight_smile:

Yep, just send me a pm when you have another mesh with the same problem. :wink:

Prepare yourself for a long day/night :stuck_out_tongue: