Collision mesh problem

Collision mesh as shown in Image 1 when exported shows like in image 2. I am not able to enter in the appt. in the game play.Please help me to solve this problem

Hi Archgaur,

I’ve made a simple tutorial a short while ago that goes over some of the basics of generating custom collision that may help here: [TUTORIALS] Photons Be Free: Mini-tutorials and other curiosities - Community & Industry Discussion - Epic Developer Community Forums

There are two ways to go about this.

  • Use custom collision with separate boxes that are labeled appropriately with the UBX or UCX tag like in my link above.
  • Or, you can disable the import option “One Convex Hull per UCX” and multiple collision boxes will be generated.

I do not necessarily recommend the latter because it will generate more collision hulls than really needed which can affect performance and optimization.

Thanx Tim for your Reply. The main problem is that its entirely a single mesh and secondly i wanna go inside the apartment in the game play which i wont be able to with this kind of Collision,.yellow box in first image is Collision mesh with suffix as UCX.

You’ll want to break the wall collision into separate pieces for each wall for starters.

Looking at your Yellow boxes setup for the collision this looks to be ~30 separated boxes for each wall, which is good.

You would simply want to separate those into their own mesh and not be a single mesh.

If you look at my example linked above with the spheres you can see how I used three spheres that are all separate and named appropriately.

For example.

Your Wall Mesh with no collision can be a single mesh. Let’s just assume it’s name is set to ApartmentWalls

Next we’ll want to setup the collision UCX hulls. Since you have multiple hulls they all need to be separated and named appropriately.

… and so on until you have all the collision hulls named.

At this point, you would just export all the collision hulls and the ApartmentWalls static mesh to a single FBX.

Import this into UE4. Default settings should work.

When you open the Static Mesh you should now see multiple collision hulls (you can check the indicator for number of hulls in the top right of the viewport in the Static Mesh Editor to see this).

Let me know.


Thanx Tim. for your valuable advice I will surely try it.

Hello Tim, if you’re still around. I’m encountering a related issue with collision, with significant differences. I’m in 4.17 working with photogrammetry data of a cave. This SFM app can reconstruct in parts with control over max vertices per part, which I use to support occlusion culling. I enable Auto Generate Collision on import of a folder containing hundreds of FBX meshes, which is working for the most part. That is, in Play I can fly around inside the cave, a deep vertical pit and hundreds of feet of horizontal passage, but here’s the problem. In the pit there’s a particular section that always tries to stop me, have to skid around before i can finally pop through. There’s no geometry in the middle of the pit, but something is stopping me. Same in another section of horizontal cave, passage does seem to pinch down there a bit, but really nothing extreme. I’m aware of the various options in the Collision drop down menu, but have a couple questions about workflow. Firstly, why wouldn’t Default work out of the box? What could be stopping me in the middle of a pit whose walls are in umteen sections? Secondly, given I have hundreds, actually well over a thousand of these sections (40+ million tris), this would take forever to individually open each of these to edit. I see the Convex Decomposition panel features a Max hull verts value, maybe this is what I need, but how might this be configured to apply as a preference as applied globally on import? Many thanks for your help.