Collision is gone after update. How to fix?

Hi there I’m using 4.12.5,

Since a new update, I do not now which, some meshes do not have collision. I did as follows:

  1. Created a mesh with convex collision, and checked if the collision box is present.
  2. Created an actor with and instanced mesh component
  3. Added the mesh to the instance and created a few instances
  4. Put this actor into another empty actor, and dulpicated this child actor a few times.
  5. Placed this actor into my level.

This has been working for me over for at least 8 months. Now during playtesting we noticed that this actor does not has any collision!

Each help would be appreciated.

Kind regards,


PS. also checked with complex as simple collision, the collision config is on Block All, at the mesh and in the actor.

Hi ERuts,

Can you clarify a couple of things for me?

  • You mention that you updated your project, but didn’t include this as part of the steps or if it was an update from a previous version like 4.11. This would be helpful to know.
  • If it requires an update from a previous version, does the recreation using your steps above still produce the error?
  • Step 4. I’m not sure what you mean by this. Can you please explain what you are doing. The instance static mesh is already in a BP and cannot add the BP to another BP in this way, or do you mean simply to create a child actor?

If this can only be reproduce by converting a project from a previous version, can you provide the sample project and I’ll take a look. At the moment I cannot reproduce what you are reporting.

Thank you!


Hi there Tim!

I did not mention wich update because I do not now. It is an element in one of our levels, and we do not test the collision each time. We are pretty sure that it still worked in 12.0. But in 12.5 it does not. But I can’t say this with a guarantee.

It does not require an update from a previous version.

Step four does not matter for the reproduce. Just the use of an actor as an child actor in an other actor.

Follows how to reproduce:

  • Create an empty actor:
  • Add an instanced mesh component:
  • Add an mesh to this instanced mesh component
  • Ad an instance:
  • Place this actor into a level:
  • Now you will see that the mesh does not have any collision

Kind regards,


Even with these updated repro steps, I’m still not seeing the same thing. Make sure that your mesh you’re using does have collision setup and that you have it enabled in the BP instances.

If you want to attach a sample project where this occurs I can have a look since I cannot reproduce on my end.

To rule out your assets you may want to try the repro steps above in a new project with one of the static meshes included in the Engine Content folder, like the cube or sphere.