Download

Collision: Ignore Component In Actor When Moving instead of Ignore Actor When Moving?

I’m using “Ignore Actor When Moving” on the capsule of my characters to allow certain pawns to pass through ‘obstacle actors’ that block portions of the map. However this function ignores all components of that actor thus disabling not just the collider in the obstacle but also any interaction trigger zones on it as well. Is there a way to only ignore selective components on a target actor instead?

The workaround I’ve successfully used for now is to add a second capsule component for my characters that is setup with a custom collision profile that ignores colliders and overlaps interaction zones alone. Is this a reasonable setup?

Another option is to create multiple custom collision profiles (under project settings) for each category of characters in the game and also for the obstacle colliders so I can dynamically turn collisions off for a particular category of characters for the ‘obstacle colliders’ object type alone. This feels like an overkill and involves more setup work but I’m not sure if it has performance benefits compared to my workaround of attaching an additional capsule component with a custom object type on all characters/pawns.