Collision Detection

Okay so I have followed a simple hover tutorial ( [Unreal Engine 4.7+] Hover Vehicle Blueprint Tutorial - YouTube ) to make an object hover and I have another tutorial which makes a track draw from a spline ( Using Splines & Spline Components | Live Training | Unreal Engine - YouTube ) now the problem I am having is that when I draw the track from the spine the hover won’t detect the track as a collision and yes the collisions are on.

How can I fix this to work with my track spline.

Including visibility?

If you followed that first tutorial you trace by channel and in this case by visibility. Does that have collision? Did you double check if the final track has collision? Did you try walking on it / doing anything with it?

Yes I can run the normal car on it, just not the hover cat but when I drag in a normal piece of track it hovers on it fine it seems to only be when it’s generated by the spline

I will gladly rephrase my question. You trace for visibility. Do your generated parts block visibility?

Keep in mind if you simply place a static mesh it becomes a static mesh actor which defaults to certain settings your spline might not have. Check your generated track for those attributes.

Or just enable debug lines for your traces and see what happens. Try trace by objects instead of channel.

Or just look at the collision. You can select in the details of your viewport to change it from lit to player collision or visibility collision which shows you what’s going on.

This is on the track generated spline.


This is on the Spline generated track it collides but does not generate force to lift it up.

This is how the spline generates a collision I don’t get whats going wrong, I did change to trace from object but it didn’t work for me, and the collision on the track has ‘use complex collision as simple’

Okay so I got rid of it using complex collision as simple, and just auto generated one so now the object does hover a little bit but it refuses to turn

that collision I have changed my spline to doesn’t work properly when you start to add bank to the track it does not work correctly

The last picture is not your collision settings. It’s merely stating if the track will be checked by physics.

However you can still set all channels to ignore collisions and overlaps which will result in no collision as well.

You might want to take a look at this page in the documentation:

Well it seems like you will have to figure out why it’s not working anymore and why.