Download

Collision detection working only when character is moving

I’m using ACharacter class.

I have moving pads on my level and I want them to push my character out of the way.

It only works when I’m moving, but when I’m idle the pads go through my character capsule as if collision is not being checked.

I’ve already tried setting BlockAll on my character’s Capsule Component:

and on my pad Box Collision Component:

I understand that the problem is connected to the fact that ACharacter Pawns aren’t being checked for collision while idle, is there a way to change that?

I’ve finally worked it out!

The whole problem was the lack of Collision Prisms on the Static Mesh I was using.

The Static Mesh I’ve chosen had 0 collision prisms:
img4.png

after I changed to a random Mesh with 1 Collision Prism the pads started interacting with my pawn and all other objects according to the collision settings.

I hope this will help someone in the future, cheers.