Collision detection for race track not working


I’ve been trying to figure this problem out for the past couple of hours and I am really at an impasse as it revolves around this one issue. I am working on a space racing game using UE4 and I keep running into this pretty big issue as it revolves around collision for my created track.

The issue, the ship doesn’t collide with the walls I created. I am using the flying C++ base for this. I had created the track in 3DS Max (2010 ver), and I’ve imported it. I set the Collision to “Use Complex as Simple” and even allowed for CCD, but I’m getting nowhere on this.

Could anyone help me with this problem? If anyone wants a compressed copy of this current build, I could provide that if someone could help me figure out what I can do to try to get this to work (as I have tried EVERYTHING to get this to work right with no luck).

Thanks in advance.

These are really a pain to debug without more to go on. My approach is to try to narrow down which object(s) have an issue and then focus on messing with every physics related option I can find. The editor is really good at hiding stuff from new users. Keep an eye out for those sneaky little “show advanced” arrows on any editing panes.

What I do is get a new separate object like a cube that does seem to have working physics, then use that against the road and your character. Have your character bump into it and see what happens. Drop it on the road and see what happens. If it’s not reacting against one or the other, you know to start looking at the options on that thing first. Then when the cube is working against the road and your character, then start testing them against each other.

You can attach the zip of your project here as long as its under 5M. Good luck!

Thanks for the feedback. And thanks for helping me figure out an answer!

I did what you said, looked piece-by-piece, and I’ve found out that the ship was also using “Complex as Simple”, and this created the issue (where the ship would magically go through walls), changed it back through “Default” and it worked!

sweet! glad I could help!