Download

Collision components only overlap Pawns?

First, I add a collision component (without changing any properties), and then I print a string on its Begin Overlap Event. However, this is only triggered when it overlaps Pawns! Is this expected behavior? If so how can I change this?

Select the component, and change the collision settings. If the BP is an actor, then by default it’s set to OverlapAllDynamic. Change the settings to whatever you want.

I already tried that:



As you can see, it refuses to overlap the static mesh. However, it does overlap other pawns. What am I doing wrong?

Is the “Generate Overlap Events” of the static meshes checked?

Thank you, that worked! I didn’t know that every static mesh has to generate overlap events.