Collision box of destructible meshes not scaling dynamically

Using 4.7.3
Edit: tried the “Use async scene” in physicis but no luck there, tried also all the different scaling options in BP, some combination of enabling disabling physics properties in BP after the scaling without success :frowning:

Hey guys, ran into a problem earlier today, after getting a hard time trying to figure out I decided to try to reproduce it in the FPS template.

As title says it, I drag a DM from the content browser to the editor, get a reference to it in the level blueprint then scale by pressing a key.
To show the collision box of the DM you have to use the console comand `pxvis collision

Then I scale it: SetActorScale3D in LevelBP

Found a workaround though: you eject yourself and go to the detail panel of the DM:

Then you can dbl click any setting relating to physic or collision and the bounding box will update in the viewport:

Finally the final result once you re-posses the character:

Would be really cool if this is a bug and not “working as intended”, would be even more cool if I made a fool of myself and missed some obvious step in the construction of my destructible mesh.

Cheers, Tryso

Hi Tryso,

This is a known issue that has already been reported with UE-6407. Currently it is backlogged so there is no time frame for when this will be looked into and addressed.

Typically Destructibles should not be non-uniformly scaled for this reason. Scaling uniformly shouldn’t be too bad, but non-uniform scaling will result in behavior like this.

Thank you!

Tim