Every time I want to hide tabs in UE5, I pause for a second because of how oddly this feature has been renamed:
In UE4, the feature had simple and logical name:
The naming should always serve as a tool to explain the feature as clearly as possible, not for the developers to show off their linguistic skills. I am sure vast majority of the games and computer graphics software packages in the industry do not refer to tab bars as “tab wells”. When it comes to UI/UX, being inventive with the names is one of the worst things possible. I mean even the tooltip, which is supposed to explain the operation, doesn’t use the word “well” but headers instead.
Let’s rename it to something simple and logical. The UE4 had a little issue, where “Hide Tab” term could imply it hides only the single tab. That could be easily solved by just renaming it to “Hide Tabs” or “Hide Tab Header”. But there’s really no need to completely reinvent the wheel here.
I know it’s just a little detail, but it’s just not up to standards with the rest of UE UI/UX experience. And in most cases, what usually reduces the standards of UI/UX experience is not some singular big thing, but accumulation of large amount of these tiny issues.