Download

Collab Viewer Broken

Hello,

I am experiencing issues with the collaboration viewer, both in scenes that I have created and with the default scene. After packaging and hosting a session on one machine, I am completely unable to connect from any other machine. I was previously able to use this feature nicely, with only some small bugs (vr locomotion only worked on the host computer) but now clicking the join button does absolutely nothing. I have tried with 3 machines, on various networks, ensured nothing is blocked on the firewall side, etc… and still am unable to get a session to connect with the host.

Are there new settings that need to be enabled or something else I might be missing to get this up and running again? It has been a nice part of our reviews with remote locations.

Thanks,
Zack

Hello Zack,

have you tried by inputting the host IP address on the clients?

Yes, I have. I have successfully used the 4.23 previews to connect with team members in other locations. When I go through the process now and I get the “join” button, absolutely nothing happens when I click the button. No feedback, the button doesn’t “click”, the computer doesn’t do anything. And this occurs on multiple machines on both internal ethernet and a separate wifi network.

Hi,

I can connect properly after packaging a custom Project with the Collab Viewer.
My problem is that only the Host has tracking in VR and if we change the View mode on CLIENT 1 from lets say FLY to VR the other 2 CLIENTS also change to the selected View mode.
One more :wink: is there any good way to change from VR to any other mode?

Yea, I’ve been trying to knock the issues down one at a time, but we had the same issue with VR tracking only working on the Host machine when using the 4.23 preview releases.

I was hoping that the full release would fix, but haven’t been able to try it out as we still haven’t figured out a solution to the connection issues.

This should work clean out of the box! EPIC Heeeeelp…

UE_FlavienP, do you have any additional information or guidance on resolving this issue?

Hi Guys,

I’m having the same issues with the template, built out and the join button on the manual IP selection does nothing…

still waiting for some input./help from developer community. is it working for anyone ? i am able to connect with other users on same LAN network but could not connect with users on internet. i tried below things
-updated network adapters

  • open port 7777 (set inbound , outbound rule)
    -turn off firewall
    -I could not find option to set NAT rule on web interface for my router
  • changes packaging setting : changed type development to shipping
    -Also allow app through firewall (on both client and server machine)
  • tried running application through command prompt using command appname.exe -server
    seems like its not working at all. kindly guide