Cofiguring emscripten for windows

I am trying to compile emscripten following this guide.

I have compiled my UE4 from source and download everything needed for deployment.

http://kripken.github.io/emscripten-site/docs/building_from_source/configuring_emscripten_settings.html

I am currently stuck at this step.

Where exactly should I enter the command?

Hey Evenger,

Once you’re in the directory where Emscripten repository is located, press shift+right-click and that should bring up a menu. Towards the bottom of that menu, there should be an option to open the command prompt. That is where you’d enter the /emcc --help. If you need any additional information, you may want to look at this link for additional assistance.

I need some help as I’m new to unreal. I have installed python & nightly firefox as 1st installation method
(Epic game Launcher) described in https://docs.unrealengine.com/latest/INT/Platforms/HTML5/GettingStarted/index.html
Now I can’t configure emscripten.
Logging in github & download seems the second option in the link.But how can I solve it as Epic game launcher?
I will appreciate if anyone give a shortest method to solve this.


Hey Rajib,

Did you open the Emscripten Command Prompt application from Start > Emscripten > Emscripten Command Prompt? If so, within the command prompt type “emsdk install” without the quotations. After the information has populated, please then type in --old more information will appear and please wait for it all to populate. Then type “emsdk activate ‘version number’” for example: C:\Program Files\Emscripten>emsdk activate sdk-1.29.0-64bit

Once that is complete, your Emscripten should be up to date but please remember to also update your environment variables as follows:

Variable
Name: EMSCRIPTEN_ROOT
Value: C:\Program Files\Emscripten\emscripten\1.29.0 (or wherever emcc.exe is location)
Variable
Name: LLVM_ROOT
Value: C:\Program Files\Emscripten\clang\e1.29.0_64bit (or wherever llvm.exe is location)
Variable
Name: NODE_JS
Value: C:\Program Files\Emscripten
ode\0.10.17_64bit (or wherever node.exe is location)
Variable
Name: PYTHON
Value: C:\Program Files\Emscripten\python\2.7.5.3_64bit (or wherever python.exe is location)

I hope this information is useful to you. If you happen to run into any further complications, feel free to post on AnswerHub as well. Have a great day!

Hi Samantha,
So glad to hear you. I know this can embracing to help as I have 0 knowledge in this area but I’m getting mad to publish my architectural tour project with browser as my employer using mac, I’m using windows & don’t have any iPhone/mac. I hope this make sense to publish my tour in browser.
This time I opened it from start menu.
Emscripten cmd - 1.png
It shows cmake is not installed. I have downloaded manually from that address but it doesn’t have any .exe file to install
Emscripten cmd - 1.png
I typed “emsdk list --old”, then a list appeared & entered command as upper image. I did installed visual studio 12.
Where am I stuck?

Please help me.

What tutorials are you following? If you’re on a Windows computer, you should be following the Windows information, not the Mac information. Despite what your client is actually using on their end, they’re not the ones cooking and packaging the project therefore, it needs to be set up correctly on your computer.

Once you’ve uploaded the packaged project to a web server, then it will run on those browsers that it was cooked for.

Regarding CMake unfortunately, I am not sure what CMake is. Unreal Engine 4 does not use CMake, we have our own custom build tool. If you have questions on CMake, you may want to reach out to them directly or look up Unreal Engine 4 CMake to see if you can find some information from the community.

Thanks!

I am using windows 8 & engine version 4.8.2. I did followed this video once to build this from source code but failed https://www.youtube.com/watch?v=usjlNHPn-jo&list=PLFz0nbQo-iaNkJbjJ5qpdbiHhUf6aUjHE&index=4
Then I decided to follow installation method as Epic Game Launcher Developing HTML5 Projects | Unreal Engine Documentation
That’s exactly I want. I will cook & package the project & client will run the project from Nightly Firefox browser in any OS.
I am only following this forum as tutorial :). I did entered command “emsdk help”, it shows some command & tried some command on my own. Previous pictures are from there.
Please give me any suggestion to solve this quickly/asap.
Thanks for your support & will be waiting for reply.

Hey Rajib,

I’d suggest running through the following steps to ensure that the HTML5 SDK has been set up properly for 4.8.2. I will start with verifying that Emscripten SDK is up to date. Please make sure that you’ve downloaded the EMSDK for Windows onto your computer. I’d suggest version 1.25.0 or 1.29.0.

Update Emscripten SDK - Windows

  1. Open the Emscripten Command prompt application from Start|Emscripten|Emscripten Command Prompt
  2. Type in the command prompt: emsdk install
  3. Type in: emsdk list --old
  4. Type in: emsdk activate version number
    Example: C:\Program Files\Emscripten>emsdk activate sdk-1.29.0-64bit

Update your environment variables:
Variable
name: EMSCRIPTEN_ROOT
value: C:\Program Files\Emscripten\emscripten\1.29.0 (or wherever emcc.exe is location)
Variable
name: LLVM_ROOT
Value: C:\Program Files\Emscripten\clang\e1.29.0_64bit (or wherever llvm.exe is location)
**Variable **
name: NODE_JS
value: C:\Program Files\Emscripten
ode\0.10.17_64bit (or wherever node.exe is location)
Variable
name: PYTHON
Value: C:\Program Files\Emscripten\python\2.7.5.3_64bit (or wherever python.exe is location)

Here are the steps to set up HTML5 SDK for 4.8.2:

Setup Empscripten SDK Path:

  1. Select Edit > Project Settings > Platforms > HTML5 SDK
  2. Select the ‘…’ button to the right of the ‘Location of Emscripten SDK’
  3. Browse to install directory of the Emscripten SDK
    e.g. - C:/Program Files/Emscripten
    e.g - Macintosh HD/Emscripten

Setup Python.exe Path:

  1. Select Edit > Project Settings > Platforms > HTML5 SDK
  2. Select the ‘…’ button to the right of ‘Location of Python.exe’
  3. Browse to the location of the Python.exe
  4. Select the Python.exe then select ‘Open’
    e.g - C:/Program Files/Emscripten/python/2.7.5.3_64bit/python.exe

Setup Browsers for Launch On:

  1. Select Edit > Project Settings > Platforms > HTML5 SDK
  2. Select the + button under the HTML5 Devices section
  3. Enter a Browser name that will appear in the Launch On menu
  4. Select the ‘…’ button to the right of Browser filepath
  5. Navigate to the browser’s executable file
  6. Select the browser’s executable file then select Open

Hopefully these detailed steps will fix the issue that you’re running into with HTML5 SDK. If you have any further questions, feel free to ask and remember you can always post a question AnswerHub.

Have a great day!

I believe you need CMAKE and Visual Studio for the web installer, try the Offline Installer instead, that worked for me though now I have issues with getting my Chrome 64bit browser to show up on the Unreal Engine Device Manager.

Edit:

Ok I got it to work by setting all the parameters in the Unreal Engine Editor: Edit > Project Settings >HTML5 SDK (instead of changing the config file which the official documentations states).

Also, it works on Firefox but not Chrome for me (both 64bit).

Doing configure is turf any time generator any error.