Code is missing

Hi, i tried to attach sword from right hand socket.

But when i try to watching this link its make a different or some is missing to this link “- YouTube

Please can you help me. thanks.

Where exactly You’re experiencing problem?
Show what are You expecting to see and what are You actually see.

p.s.: You can copy exact time link in Youtube (right click → Copy URL at current time)

I just follow the instructor here at the youtube. but i think there are code change to 4.5.1 by creating blueprint in socket code.

Note: Starting tutorial at 2:20.


Hey -

What is the problem you’re having when following the tutorial? Are you getting an error message or are you unable to create the socket or attach to it? Providing as much information about what the problem is will help us solve it and come up with a solution sooner.


Oh. Now I’ve got Your problem.

There is no Attach Actor node in Level Blueprint menu.

I don’t know it’s bug or feature, but You can copy one from Actor Blueprint.

I don’t know the reason, but there are different sets of Nodes for Level and Actor Blueprints.

You still can freely copy them in between.

Hey and -

If you turn off context sensitivity in the right click menu you should see the “Attach Actor to Component” option in the drop down menu.


Nope. If New Blueprint Menuing System enabled.
Working with disabled one.

Hey -

So just to clarify, unchecking the box for “Use New Blueprint Menuing System” in the Experimental heading of Editor Preferences allowed the context sensitivity to function properly for you?

I tried also that but its not show. I thinking its some but from code list. I can’t follow your code because its every UE4 version its going changes :).

Hey -

As suggested, go to Edit->Editor Preferences and then select Experimental under the General heading. In the experimental preferences there is a checkbox for “Use New Blueprint Menuing System.” Unchecking this checkbox should fix context sensitivity issue.

Its already un-check?! before As she/he requested.

alt text

Just to clarify, when you uncheck Use New Blueprint Menuing System and uncheck Context Sensitive in the level blueprint, you are still not seeing the option for Attach Actor to Component, correct? Also, which version of the engine are you working in?

Yes.UE4.5.1…I tried again with HeroTPP Skeleton now its show the same from Youtube. I think there some problem when using Mixamo Skeleton. But how come what its difference, its only a Mixamo character and also i encounter bug from my last Post “Bug can’t drag FollowCamera under SpringArm”.

Note: Same Maximo Character using!
Link: Bug can't drag FollowCamera under SpringArm - Character & Animation - Unreal Engine Forums

But its only character, and not editor or blueprint code?

Hey -

In the Level Blueprint, if you go to Window-> Palette this will add the palette tab next to the event graph tab. In the “Find a Node” section, you can type in “Attach” or manually navigate to Library → Utilities → Transformation and find the Attach Actor to Component node there. Adding the node to the level blueprint should be independent of if you are using HeroTPP or a Mixamo character.


Sorry, Good day… i tried again its show error. Please check the attachment files. Thanks

Note: Two (2) attachment.

  1. My Blueprint and My Skeleton
  2. Youtube Example

Hey -

When you create the “Attach Actor to Component” node, if you have the mesh selected in the content browser (in your case the BookLP) it should link it as the target automatically. Alternatively, you want the target to be the mesh you are attaching. In the case of the video he gave the socket the same name as the mesh he was using (messer) however in your case you would want to use BookLP when dragging off of the Target pin.

Messer its only socket name and the another is sword name. But here at youtube. When you type the Attach Actor to Component the messer its also automatic show (check the photo). But in my chase its not show.

The reason it automatically shows in the video is because the mesh is selected in the scene outliner. If you have the mesh (BookLP) selected in the scene outliner then it will show up already connected to the target of the attach actor to component node.