Cmd.exe failed with args: Rungradle.bat. Packaging for android


I have been working all day trying to get my game onto google play. I created a keystore and everything stopped working. As you can see in the image, it says something about the game failing to read the keystore (I did everything the ue4 doc said to do, but the command prompt didn’t give me a key password, just a keystore password). And it also says something about failed with args at rungradle.bat, and I’ve actually had this problem before. I solved it by turning my security off because my computer was blocking the package from working, but I did this time and it still won’t work. I’m using UE4 4.26, just as an FYI. Everything worked fine until I messed around with the keystore, and I’m very confused on how to move forward. Any help would be appreciated.


keytool -genkey -v -keystore ExampleKey.keystore -alias MyKey -keyalg RSA -keysize 2048 -validity 10000
  1. enter your details there it says what need Screenshot_49
  2. move the generated key to the folder with your game
  3. the password must be the one you entered when generating the key

//it’s the whole process)) where you make a mistake you can look … I uploaded in the play market there were no problems … of course you may have a different project name or java location or key name))

I didn’t have the setting set to shipping, so I changed that. And I did the process you showed, but it still gives me the same error messages, I have JDK 16.0.2 if that makes a difference. It also still didn’t give me a key password, just a keystore password. But thank you for your help :slight_smile:.
Here is the log after the cmd.exe failed with args line (Sorry, wasn’t able to get the full log, it’s super long):

that’s your problem JDK! install

I don’t understand it a bit …
here are the instructions of the epic … set the correct java and try

Yeeessss, it works now! When I said it wasn’t giving me a key password, but it was giving me a keystore password, this is what I meant:
I got the prompt this time. Everything’s working good now. Thank you!