Clothing data wont generate?

Hello,

I’ve have created this hood within blender, and i exported it as an FBX. I then imported it into UE4 for cloth simulation, and i intend to put this on my third person character.

However, once i click on the “section selection” tool, and select the hood to generate the clothing data, nothing generates at all. As you can see in the screenshot, i have the clothing window docked on the right side of the screen, and the generated clothing data should show up there correct? But once i click create, UE4 freezes for a moment, as if its processing the data, but nothing shows or changes. Am i doing something wrong?

Try to reopen the asset. Sometimes that window doesn’t update after cloth creation.

is there any update on this ? i’m also trying to create data for clothing and it’s getting anywhere,
Can’t seem to get Data created.

Same problem here. No idea what’s the issue.

Hit the Window tab in the top left and make sure Clothing is checked. This should add the clothing window which you can then dock next to Asset Details and Skeleton Tree on the left.

Same. Have several cloth assets on my character. Some create clothing data, other don’t)

I’ve been trying to troubleshoot the same problem for the last few hours and can’t figure out why the model I built in Blender can’t even be selected to right-click and generate clothing data.

Any solutions out there? What am I doing wrong with my Blender creation/export/import?

I was struggling with this problem. I was doing it on a hi-res asset which worked for film but had topology issues, thickness, self-intersection etc. It defintely wasn’t clean but looked great.

I retopo’d the garment (plus baking normals) and tried agian with a game friendly version. It then worked.

That said your geo looks pretty simple but there could be these issues present? I am working with maya just in case you are interested.

This was a solution that worked for me to get it to work:
I was having the same issue with hair, I went back into Blender and used the “Decimate” modify to get the total poly count under 10K, then when I reimported it worked. Seems that too high res breaks it.

another thing to try is make sure there are no overlapping verts - in blender, select your asset, go to edit mode, select all the verts and click “M” for merge, and merge by distance - I think you want to do a distance of something like .0001 or .001 - it will drop overall poly count too, but if any verts are sharing the same space things get messed up.